[Live-demo] Problems with 10.5 and VirtualBox 5.1

Stephen Woodbridge woodbri at swoodbridge.com
Sat Jun 10 11:34:44 PDT 2017

Hi Cameron,

I create an updated version of


based on VirtualBox 5.1 and added some information about Windows.

Since VirtualBox 5.1 is the current download and the dialogs are a 
little bit different from the previous versions. You will probably want 
to update the documentation using these images.

You can download it from:


You will need to move the images into your folder and update the links 
to reflect the changes, but this should reduce the effort and help you 
with updating the docs.

One thing that I did not mention, is the fact that if a user generates a 
32-bit VM then they can NOT use the OSGeoLive vmdk as that is a 64-bit 
vmdk. It is possible to build a 32-bit VM based on the 32-bit ISO image, 
but it is a little bit fiddly to get it running, but that might just be 
my lack of knowledge on these things.


On 6/9/2017 5:41 PM, Cameron Shorter wrote:
> Thanks Stephen for sharing what you have been finding out about running 
> in a virtual machine.
> The places where we are collecting this information are:
> https://live.osgeo.org/en/quickstart/virtualization_quickstart.html 
> (official location)
> https://live.osgeo.org/en/quickstart/osgeolive_install_quickstart.html 
> (official location)
> https://wiki.osgeo.org/wiki/Live_GIS_Virtual_Machine
> It would be awesome if you could collect what you are learning (and 
> correct outdated material) in one of these locations such that it can 
> become useful for those who follow in your footsteps.
> Cheers, Cameron
> On 9/6/17 11:42 am, Stephen Woodbridge wrote:
>> On 6/8/2017 3:11 PM, Micha Silver wrote:
>>> On 06/08/2017 08:52 PM, Stephen Woodbridge wrote:
>>>> Hi all,
>>>> I just tried to install OSGeo Live 10.5 on Windows using VirtualBox 
>>>> 5.1 and ran into a bunch of problems. I will allow for that fact 
>>>> that this is my first attempt to do this, but want to document the 
>>>> issues.
>>>> 1. Follow the link to get VirtualBox and installed it on Windows 10 
>>>> 64-bit machine.
>>>> 2. tried to install vmdk following the instruction, I could not get 
>>>> this to work. Issues are:
>>>> * VirtualBox Dialogs are different on 5.1, but could basically 
>>>> follow the intent.
>>>> * when I tried to start the VM it launches and I get black screen 
>>>> with _ cursor and nothing more. Powered off VM, restarted it, same 
>>>> result. Could not find a work-a-round to this issue
>>>> 3. Created a new VM using the 32-bit iso. For some reason, 
>>>> VirtualBox would not allow me to create 64-bit VM, so its a good 
>>>> thing you supplied a 32-bit iso also.
>>> You'll find the answer to the 32bit-only problem here:
>>> https://superuser.com/questions/866962/why-does-virtualbox-only-have-32-bit-option-no-64-bit-option-on-windows-7 
>> Here is how to get into your Windows 10 BOIS if anyone cares:
>> https://www.laptopmag.com/articles/access-bios-windows-10
>> And here is a good explanation from VirtualBox
>> https://forums.virtualbox.org/viewtopic.php?f=1&t=62339
>> After finding this and enabling VT-x I was able to create a 64-bit VM 
>> and use the vmdk with that without any problems. Click the Run button 
>> brings me right into OSGeo Live.
>>>> * Launching this VM, fails with No boot disk error.
>>>> * Launching this VM and quickly hiting F12 key, brings up boot 
>>>> options and selecting "c" to boot from CD-ROM, boots into Linux 
>>>> installation Menu
>>> Are you trying from the ISO file, or a CD? Maybe you did not add the 
>>> CDROM in the VM settings? Under Storage->ContollerIDE be sure that 
>>> the machine's CDROM drive is selected: Use the "CD icon" to browse 
>>> and select your CDROM drive. Then check the "Live CD/DVD" checkbox, 
>>> and try to boot.
>> In this case I build the VM from the ISO not the CD-ROM.
>>>> * If you select "Try Linux without installing" from the menu, it 
>>>> brings up OSGeo Live, but no where are these steps documented and I 
>>>> tried menu options before discovering this.
>>>> 4. Once in OSGeo Live, I could not access my shared folder. It took 
>>>> me some time to work around this but eventually this worked:
>>>> sudo umount /media/sf_SharedFolder
>>>> sudo chmod 777 /media/sf_SharedFolder
>>>> sudo mount -t vboxsf -o rw,nodev,uid=0,gid=120  SharedFolder 
>>>> /media/sf_SharedFolder
>> And doing sudo adduser user vboxsf
>> and logout and back in fixed the shared folder issue.
>> So making progress, thanks all. I'll be working with Brian and Vicky 
>> to provide feedback and do testing.
>> Thanks,
>>   -Steve
>>>> I noticed the rc.local adds vboxsf group to user, but it does not 
>>>> appear in the user account:
>>>> user at osgeolive:/media/sf_SharedFolder$ id
>>>> uid=999(user) gid=999(user) 
>>>> groups=999(user),4(adm),20(dialout),24(cdrom),27(sudo),29(audio),30(dip),33(www-data),46(plugdev),50(staff),100(users),121(tomcat8),125(lpadmin),126(sambashare) 
>>>> I'll be using OSQeo Live at FOSS4G Boston to present the pgRouting 
>>>> Workshop.
>>>> -Steve
>>>> ---
>>>> This email has been checked for viruses by Avast antivirus software.
>>>> https://www.avast.com/antivirus
>>>> _______________________________________________
>>>> Live-demo mailing list
>>>> Live-demo at lists.osgeo.org
>>>> https://lists.osgeo.org/mailman/listinfo/live-demo
>>>> http://live.osgeo.org
>>>> http://wiki.osgeo.org/wiki/Live_GIS_Disc
>>> -- 
>>> Micha Silver
>>> cell: +972-523-665918
>> _______________________________________________
>> Live-demo mailing list
>> Live-demo at lists.osgeo.org
>> https://lists.osgeo.org/mailman/listinfo/live-demo
>> http://live.osgeo.org
>> http://wiki.osgeo.org/wiki/Live_GIS_Disc

More information about the Osgeolive mailing list