[pdal] Trouble reading CyArk .e57 point clouds

Carl Godkin cgodkin at gmail.com
Thu Mar 19 14:39:57 PDT 2020

Hi Andrew,

Thanks for the reply.

As I mentioned, I found that most of the projects are very big (10's of GB
to over 100 Gb!) but I found one relatively small one (~900 MB) but "pdal
info" was happy with it.  I found another one that's just over a 1Gb and
PDAL could read that too.

Could there be some sort of size assumption in PDAL or readers.e57, like
maybe a 32-bit size or offset somewhere?  The readers.e57 page in the docs
mentions a couple of caveats about this format but I imagine the tools
would warn if one of these problems was encountered, right?

I randomly tried another relatively small (for CyArk; ~4 GB) file and "pdal
info <file> --metadata" returned a different error:

>pdal info kz88-9d21_lidar_photogrammetry.e57 --metadata
PDAL: readers.e57: 29 : fileName=kz88-9d21_lidar_photogrammetry.e57
header.filePhysicalLength=4803256320 file->length=508289024

Anyone may download it by starting at
https://openheritage3d.org/project_thankyou.php?id=ck42-e122 and following
the "Download" link (which leads to a form and then they mail you a real
link to a .zip.)

Thanks for any ideas,


On Thu, Mar 19, 2020 at 12:16 PM Andrew Bell <andrew.bell.ia at gmail.com>

> If you can make a smaller version of a file available, I'll take a look.
> On Thu, Mar 19, 2020 at 2:40 PM Carl Godkin <cgodkin at gmail.com> wrote:
>> Hi,
>> I am new to PDAL so I hope this isn't a seriously dumb question.  I
>> looked in the mailing list archives and under Issues on GitHub so maybe
>> it's not.
>> CyArk makes their data available in .e57 format and I was hoping to use
>> PDAL to play with some of them.
>> However, for both of the .e57 files I've downloaded so far, "pdal info"
>> says simply
>> PDAL: readers.e57: 21 : fileName=USP_USS_Pampanito_Complete.e57 offset=0
>> whence=2 result=-2118361088
>> and exits.  I tried "pdal translate" also and its verbose flag tells me
>> that the "libpdal_plugin_reader_e57.dll" is loaded and initialized before
>> exiting with the same message.
>> My environment is Windows 10 with PDAL installed following the
>> instructions under the "Workshop" section on the pdal.io site.  (Using
>> miniconda, created a virtual environment, installing PDAL, etc.)
>> pdal --version is "pdal 2.0.1 (git-version: Release)"
>> These files are really big by the way.  The downloads are .zip files
>> which expand to 7Gb and up!
>> I was able to open this file in Cloud Compare so it's not corrupt, and
>> I've tried another file from their site as well with the same results.
>> Any ideas?  Thanks a lot!
>> carl
>> _______________________________________________
>> pdal mailing list
>> pdal at lists.osgeo.org
>> https://lists.osgeo.org/mailman/listinfo/pdal
> --
> Andrew Bell
> andrew.bell.ia at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/pdal/attachments/20200319/bc3a8bc6/attachment.html>

More information about the pdal mailing list