[postgis-devel] CLUSTER in 8.3

Obe, Regina robe.dnd at cityofboston.gov
Fri Dec 5 04:03:05 PST 2008

> Yuck. If you can definitely confirm that this works on 8.3.3 but not
> 8.3.5 then it's probably work a post on -hackers :(

> ATB,

> Mark.

I ran Kevin's test on 8.3.1 on windows and it ran fine.

create temp table tmp as select st_makepoint(random(), random()) as
the_geom from generate_series(1, 10000);
create index tmp_geom_idx on tmp using gist (the_geom);
analyze tmp;
select count(*) from tmp;

count = 10000

But note I ran Paul's test on 8.3.5 install and got mixed results.  I
could make it happen only
once and couldn't get it to happen again.  I haven't tested the above on
the 8.3.5 install
to see if it consistently breaks. So needless to say it seems more than
8.3.5 may be needed to trigger this condition.

The substance of this message, including any attachments, may be
confidential, legally privileged and/or exempt from disclosure
pursuant to Massachusetts law. It is intended
solely for the addressee. If you received this in error, please
contact the sender and delete the material from any computer.

More information about the postgis-devel mailing list