[postgis-devel] Several problems with shapeloader GUI

Paragon Corporation lr at pcorp.us
Thu Dec 24 20:36:30 PST 2009

Which version of PgAdmin III are you running under?  It seemed to work fine
for me in both modes.  though it did crash once for me under my windows
vista box, but ahven't been able to recreate that.  And the import correctly
does both geography/geometry in both modes for me.
I've been running against 1.10.1 .
I haven't tried against one that has a gid in it already though.


From: postgis-devel-bounces at postgis.refractions.net
[mailto:postgis-devel-bounces at postgis.refractions.net] On Behalf Of Nicklas
Sent: Thursday, December 24, 2009 7:30 PM
To: PostGIS Development Discussion
Subject: [postgis-devel] Several problems with shapeloader GUI

I have not tried the shapeloader GUI before because of the compiling
problems in windows.
Now I tried it.
It looks great, but I had some problems.
Just before I sent this I found that the result was very different when
running as standalone see bottom of mail
1) If I change SRID from -1 to 32633 I get following error:
Connection: user=postgres password=postgres port=5433 host=localhost
Destination: public.vegen
Source File: D:\Askprosjekt\vegen
Shapefile type: Arc
Postgis type: LINESTRING[2]
Invalid SRID for geography type: 7f79
Shapefile import failed.

I have not asked for geography and not checked it or changed anything else
under options.
I see if I try SRID -1 too, that it asks for values in long lat range.
2) If I get any error, for instance the above, when I open dialog for
choosing shapefile it doesn't filter for shapefiles anymore and shows all
3) If I try to load with srid -1 it totally flips. The progress bar seems to
extend the window of the loader GUI out to the left as showed in attached
4) As seen on the picture there is also some error happening probably
because the shapefile already contains a gid column.
Environment is 
windows XP
postgresql 8.4.2
postgis is the experimental build from 23 dec
ran loader GUI as plugin to pgAdmin. Getting connection properties
automatically worked perfect :-)
When I tried as standalone it worked very good. The only thing that seems
unstable in standalone is that when first file is loaded the shape file
filter doesn't work when I open the file dialog for the next file.
I haven't done those tests very thoroughly so I can have missunderstood
something, but this was what I got.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-devel/attachments/20091224/413f35c5/attachment.html>

More information about the postgis-devel mailing list