[postgis-devel] PSC vote Request: Make Geos 3.5 the default in PostGIS 2.2

Paragon Corporation lr at pcorp.us
Sat May 30 20:01:29 PDT 2015


This is just for PostGIS 2.2 and the plan is since some very popular
functions in PostGIS 2.2 will not work without GEOS 3.5, then GEOS 3.5 WILL
BE released before or very near PostGIS 2.2.  
Just as PostGIS 2.2 has to be released before or very near release of
PostgreSQL 9.5

strk -- you know that right that you have to pull the plug on GEOS 3.5.0
before PostGIS 2.2.0 can go out the door.

Now regarding the 6-months running -- wouldn't you have the same issue with
using PostGIS 2.2 right out of the gate? If you do, you'd probably wait for
6-months for that too
So it would be a non-issue.

Same thing with PostgreSQL 9.5 - some key features in 2.2 will only be
available to PostgreSQL 9.5 users.

I'm not saying we should require 3.5, I'm just saying that if you've got 10
packages to worry about,  normally if you compile stuff and it gives no
warning and all tests pass, you think you have all the great functionality
of the new release,
And my point is that without 3.5, you are missing a couple of key pieces
that make PostGIS 2.2 worthwhile to even consider over PostGIS 2.1, so you
should be warned so you don't get users complaining about how this function

"Requires GEOS 3.5.0" 

and it's a pain to try to do something about it.


-----Original Message-----
From: Greg Troxel [mailto:gdt at ir.bbn.com] 
Sent: Saturday, May 30, 2015 8:14 PM
To: Paragon Corporation
Cc: 'PostGIS Development Discussion'
Subject: Re: [postgis-devel] PSC vote Request: Make Geos 3.5 the default in
PostGIS 2.2

"Paragon Corporation" <lr at pcorp.us> writes:

>> I suppose it would be mean to completely block compiling PostGIS 2.2 
>> against a geos lower than 3.5, however, how about a compromise:
>>> We make GEOS 3.5 the default and if someone wants to compile with a 
>> lower GEOS, then they need to pass in an extra parameter to do this.
>>> Why do I want to make GEOS 3.5 the default and make it a deliberate 
>>  decision to compile with lower GEOS

> Speaking as the maintainer of several packages in pkgsrc:

* geos 3.5 does not seem to be actually released.  So I have a hard time
  understanding the notion of requiring it.

* generally, things need to be updated sequentially.  So as a general
  rule, I would say that postgis should only depend on versions of other
  things that have been released and advisable to run for at least 6
  months.  I mean that when geos 3.5.0  is released, there will be a
  period when standard advice is to stay away vs update
  immediately. Then opinions will change that it is the right approach.
  Six months after the opinion shift, it's time to consider making
  postgis depend on it.

* I can understand that you're probably frustrated about geos
  non-release schedule.  But it's madness to have programs depend on
  unreleased code.  People who work on postgis probably don't mind so
  much, because it's not so much work to track geos unstable.  But from
  a packaging and regular user point of view, it's not reasonable.

Sorry if I got the facts wrong: geos 3.4.2 looks to be the latest:


and that is what is in pkgsrc right now.


More information about the postgis-devel mailing list