[postgis-devel] PSC vote Request: Make Geos 3.5 the default in PostGIS 2.2

Greg Troxel gdt at ir.bbn.com
Sat May 30 17:14:07 PDT 2015

"Paragon Corporation" <lr at pcorp.us> writes:

> I suppose it would be mean to completely block compiling PostGIS 2.2 against
> a geos lower than 3.5, however, how about a compromise:
> We make GEOS 3.5 the default and if someone wants to compile with a lower
> GEOS, then they need to pass in an extra parameter to do this.
> Why do I want to make GEOS 3.5 the default and make it a deliberate decision
> to compile with lower GEOS

Speaking as the maintainer of several packages in pkgsrc:

* geos 3.5 does not seem to be actually released.  So I have a hard time
  understanding the notion of requiring it.

* generally, things need to be updated sequentially.  So as a general
  rule, I would say that postgis should only depend on versions of other
  things that have been released and advisable to run for at least 6
  months.  I mean that when geos 3.5.0  is released, there will be a
  period when standard advice is to stay away vs update
  immediately. Then opinions will change that it is the right approach.
  Six months after the opinion shift, it's time to consider making
  postgis depend on it.

* I can understand that you're probably frustrated about geos
  non-release schedule.  But it's madness to have programs depend on
  unreleased code.  People who work on postgis probably don't mind so
  much, because it's not so much work to track geos unstable.  But from
  a packaging and regular user point of view, it's not reasonable.

Sorry if I got the facts wrong: geos 3.4.2 looks to be the latest:


and that is what is in pkgsrc right now.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 180 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/postgis-devel/attachments/20150530/4a41a754/attachment.sig>

More information about the postgis-devel mailing list