[postgis-devel] Recommended GEOS version for PostGIS-3.0.0alpha1 (was: PostGIS 3.0.0alpha1 released)

Sandro Santilli strk at kbt.io
Mon May 27 11:01:45 PDT 2019

On Sun, May 26, 2019 at 03:43:36PM -0400, Regina Obe wrote:
> The PostGIS development team is pleased to release PostGIS 3.0.0alpha1.

I'm testing the tarball. On configure I get this warning:

  configure: WARNING:  --------- GEOS VERSION WARNING ------------
  configure: WARNING:   You are building against GEOS 3.6.4dev
  configure: WARNING:   To take advantage of all the features of
  configure: WARNING:   this PostGIS version requires GEOS 3.7.0 or higher.
  configure: WARNING:   To take advantage of most of the features of this PostGIS
  configure: WARNING:   we recommend GEOS 3.6 or higher
  configure: WARNING:   You can download the latest versions from
  configure: WARNING:   http://trac.osgeo.org/geos

The message is very confusing becuase "we recommend GEOS 3.6 or higher"
but then why the warning about using 3.6.4dev ? And why "requires GEOS
3.7.0 or higher" ? message ?

What's the state here ? What do we want users to use ?


More information about the postgis-devel mailing list