[postgis-tickets] r16056 - Comment out unused static function

Sandro Santilli strk at kbt.io
Wed Oct 25 01:44:48 PDT 2017


On Tue, Oct 24, 2017 at 12:56:35PM -0700, Paul Ramsey wrote:
> Author: pramsey
> Date: 2017-10-24 12:56:35 -0700 (Tue, 24 Oct 2017)
> New Revision: 16056
> 
> Modified:
>    trunk/liblwgeom/lwgeom_topo.c
> Log:
> Comment out unused static function

>  /* Return the smallest delta that can perturbate
> - * the given point */
> + * the given point
>  static inline double
>  _lwt_minTolerancePoint2d( const POINT2D* p )
>  {
> @@ -5023,6 +5023,7 @@
>    if ( max < FP_ABS(p->y) ) max = FP_ABS(p->y);
>    return _lwt_minToleranceDouble(max);
>  }
> +*/

It would be more readable (and safer) to use the pre-processor
for this (#if 0 / #endif) - but we could as well just drop the
function as we're keeping all history anyway...

--strk;


More information about the postgis-tickets mailing list