[postgis-users] compiling postgis with postgres 7.3 and cygwin

Norman Vine nhv at cape.com
Wed Jan 1 08:17:55 PST 2003

Klaus Benndorf writes:
> I tried to install postgis under Windows XP, following the "NON-UNIX
> User's Guide". Everything worked fine and I had no problems with
> configure and make of Postgres. But now make of postgis shows a lot of
> undefined references. In the mailing list I found the hint, that
> libpostgres.a might be not found, but it exists and I copied it to
> different directories, that are definded in Makefile.
> Any idea what to do?

For some reason the PostGIS Makefile is not adding -lpostgres to
the dllwrap command :-(

The attached Makefile works for me

also see
for a required change to the postgresql source
< although this mentions the 7.2.3 tree this still applies to the 7.3.x tree >


-------------- next part --------------
A non-text attachment was scrubbed...
Name: Makefile
Type: application/octet-stream
Size: 4040 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20030101/1bc15da9/attachment.obj>

More information about the postgis-users mailing list