[postgis-users] postgis.sql is failing

strk strk at freek.keybit.net
Tue May 13 08:51:36 PDT 2003

Find postgis.dll on your disk.
In the same directory in which postgis.dll resides (postgres libs)
there should be another directory named 'postgresql'. Is this correct ?
If so, move postgis.dll inside this directory and try again.


ybaykshtis wrote:
> I followed PostGIS Windows installation steps described here:
> http://www.gasai.com/gisapps/WindowsHowTo.html
> Everything was OK (cygwin, ipc, postgres, build) till the following
> statement:
> psql -U postgres -d myGISdb -f postgis.sql
> I got the following errors
> psql:postgis.sql:18: NOTICE:  ProcedureCreate: type histogram2d is not
> yet defined
> psql:postgis.sql:18: ERROR:  stat failed on file '$libdir/postgis.dll':
> No such file or directory
> And then just whole bunch of these:
> psql:postgis.sql:23: ERROR:  current transaction is aborted, queries
> ignored until end of transaction block
> Then I tried to execute postgis.sql from the GUI tool (pgAdmin II) and
> got the same error:
> stat failed on file '$libdir/postgis.dll': No such file or directory
> I appreciate if anybody could explain what should I do here.
> _______________________________________________
> postgis-users mailing list
> postgis-users at postgis.refractions.net
> http://postgis.refractions.net/mailman/listinfo/postgis-users

More information about the postgis-users mailing list