[postgis-users] Problems with installing on Cygwin

Will Shaw wshaw at neo.tamu.edu
Wed Nov 12 14:44:55 PST 2003

Hello List,

I'm having a little problem with installing postgresql for use with the new

Windows XP
Cygwin 1.5.5-1
Postgresql 7.3.4-2 (source from Cygwin)

I ran the configure script like this:

$ LDFLAGS=-lstdc++ ./configure --enable-multibyte --with-CXX --prefix=/usr 
--sysconfdir=/etc --docdir=/usr/doc/postgresql-$version

And then did a make and make install

The make apparently worked fine, it gave me the message "Postgresql made
successfully" and there were no apparent problems with make install.

I then ran

$ ipc-daemon2 &
$ initdb -D /usr/share/postgresql/data

And got the following output:

The files belonging to this database system will be owned by user
"postgres". This user must also own the server process.

The database cluster will be initialized with locale C.

Fixing permissions on existing directory /usr/share/postgresql/data... ok
creating directory /usr/share/postgresql/data/base... ok creating directory
/usr/share/postgresql/data/global... ok creating directory
/usr/share/postgresql/data/pg_xlog... ok creating directory
/usr/share/postgresql/data/pg_clog... ok creating template1 database in
/usr/share/postgresql/data/base/1... IpcSemaphore
Create: semget(key=1, num=17, 03600) failed: Function not implemented

initdb failed.

Just to make sure there was nothing wrong with ipc-daemon2, I installed the
binaries using the Cygwin setup program and tried to initialize the database
again and it worked.  Does anyone know what the problem might be?  Any help
would be greatly appreciated.


Will Shaw
PhD Candidate
Texas A&M University

More information about the postgis-users mailing list