[postgis-users] ": can't parse "ne 1, pg_atoi: error in " & empty strings in shp2pgsql output...

Norman Vine nhv at cape.com
Sat Sep 13 17:47:41 PDT 2003

Mike Leahy writes:
> I’ve just installed Cygwin (on WinXP) and compiled the latest available
> versions of PostgreSQL/PostGIS.
> When I run a COPY query to import data from a tab-separated DOS-text file I
> get the following message:
> ": can't parse "ne 1, pg_atoi: error in "
> Sometimes it’s followed by a number.  I know this is caused because my data
> files are windows text files - when I convert the files to UNIX text files
> using UltraEdit32, it works fine (though I now have to specify that empty
> strings are null values).  I know that this problem is specifically to do with
> the PostgreSQL - but I'm just curious if anyone on this list knows of an easy
> fix that doesn’t require converting all my files...perhaps a setting in Cygwin
> or something (I’ve already tried installing it with the DOS file setting, and
> I’ve tried compiling PostgreSQL/PostGIS with all the fopen or popen commands
> with the t argument for text).

d2u part of the cygutils package might be easier then using an editor

If that isn;t satisfactory I would try asking this question on the
Cygwin PostgreSQL list
mailto:pgsql-cygwin at postgresql.org


More information about the postgis-users mailing list