[postgis-users] Differences between postgis on Windows and Unix?

Benjamin Thelen thelen at ccgis.de
Thu Jan 27 13:19:31 PST 2005


I installed postgresql-8.0-release on Windows, selected postgis, too and
tried to import (first COPY, then INSERT) data, which I had dumped from
postgresql-7.3.8/postgis-0.8.1. Usually, importing data caused messages
like "function already existing", but nevertheless it worked. Not so with
the windows postgres/postgis. Nothing was imported, even no table created.

I found out, that three columns are missing in "geometry_columns":
attrelid oid
varattnum int4
stats histogram2d

I added the missing columns manually, manipulated the dump manually, but
without success importing the data cleanly. I wouldn't really mind, but I
can't display the postgis-data with mapserver.

I then downloaded Windows postgis 0.9.1, reinstalled postgres without
postgis, but it the same.

I searched google and the list, but I don't get an idea.

Can somebody help, give me a hint?


More information about the postgis-users mailing list