[postgis-users] Differences between postgis on Windows and Unix?

Benjamin Thelen thelen at ccgis.de
Fri Jan 28 10:48:33 PST 2005

strk at refractions.net wrote:
> The missing columns in geometry_columns are due to postgresql 8.0
> making them unneeded (it supports used-defined statistical analisys).


Ok, not surprising that this hasn't happend accidently. :-) So this is
not a Windows/Unix thing, I'll maybe face the same while upgrading my 
Unix machines to pg-8. :-(.

> You should first install postgres, then postgis, then restore the
> dump (and this last step whould give you the warnings/errors).

Well, I'm not sure what's going on. After removing the last three 
values (instead of adding the missing columns) of the INSERTs from 
geometry_columns within the "Unix/PG7-dump", the dump went through, of 
course complaining about existing functions, etc. and I was able to 
see data from WinPG-8 for the first time! Cool, although I further 
prefer Unix.

But what would be your migration guide line to the user? Editing the 
dump? Adding the missing columns?
The first could be problematic in case of a dump of a big size, e.g. 3 
GByte! Probably the second way should do it, too, then without the 
need of opening a huge dump.

I succeeded by using Win-postgis 0.9.1, not the 0.8.x dilivered with 
WinPG-8. Don't know if that's a matter.


> --strk;
> On Thu, Jan 27, 2005 at 10:19:31PM +0100, Benjamin Thelen wrote:
>>I installed postgresql-8.0-release on Windows, selected postgis, too and
>>tried to import (first COPY, then INSERT) data, which I had dumped from
>>postgresql-7.3.8/postgis-0.8.1. Usually, importing data caused messages
>>like "function already existing", but nevertheless it worked. Not so with
>>the windows postgres/postgis. Nothing was imported, even no table created.
>>I found out, that three columns are missing in "geometry_columns":
>>attrelid oid
>>varattnum int4
>>stats histogram2d
>>I added the missing columns manually, manipulated the dump manually, but
>>without success importing the data cleanly. I wouldn't really mind, but I
>>can't display the postgis-data with mapserver.
>>I then downloaded Windows postgis 0.9.1, reinstalled postgres without
>>postgis, but it the same.
>>I searched google and the list, but I don't get an idea.
>>Can somebody help, give me a hint?
>>postgis-users mailing list
>>postgis-users at postgis.refractions.net
> _______________________________________________
> postgis-users mailing list
> postgis-users at postgis.refractions.net
> http://postgis.refractions.net/mailman/listinfo/postgis-users

More information about the postgis-users mailing list