[postgis-users] data in mapserver

Ethan Alpert ealpert at digitalglobe.com
Wed Oct 12 15:40:03 PDT 2005

The top 4 reasons a layer doesn't show up are:
You don't have STATUS set to DEFAULT or if you have STATUS set to ON you
are not providing layers= in the your URL
You have the wrong projection
You have the wrong extents 
You are rendering at a scale that is not within your MINSCALE/MAXSCALE

	-----Original Message-----
	From: postgis-users-bounces at postgis.refractions.net
[mailto:postgis-users-bounces at postgis.refractions.net] On Behalf Of
Frances Collier
	Sent: Wednesday, October 12, 2005 4:31 PM
	To: postgis-users at postgis.refractions.net
	Subject: [postgis-users] data in mapserver

	I'm not sure if this is the correct listing to post to, but I
thought I'd give it a try. I am trying to load a layer from postgis into
mapserver. I believe I finally got the connection working correctly, but
when I run the .map through mapserver the layer does not show up. I then
tried to run the .map file through shp2img and the layer did not show
up. I have no idea what I'm doing wrong and am sure it has to do more
with my lack of experience with mapserver than postgis. Below is the
layer code from my .map file.



	     NAME "principal"

	     GROUP "roads"


	     CONNECTION "dbname=dcmms user=postgres password=w0rk1n
host=map.rapidresponder.com port=5432"

	     DATA "wkb_geometry from wacounties"

	     STATUS on

	     TYPE line


	     LABELITEM "county_nm"

	     CLASSITEM "ecy_region"

	     MAXSCALE 4000000

	     MINSCALE 80001


	          NAME "Principal Hwy"

	          EXPRESSION /Principal Highway*/


	               SYMBOL "BigLine"

	               SIZE 3

	               COLOR 171 158 137


	          OVERLAYSYMBOL "DashedLine"

	          OVERLAYSIZE 1

	          OVERLAYCOLOR 255 255 255

	#         TEXT ([FEATURE],[NAME])


	               TYPE truetype

	               FONT "arial"

	               MINFEATURESIZE 50

	               MINDISTANCE 100

	               ANGLE auto

	               COLOR 0 0 0

	               SIZE 8





	Any help or direction is greatly appreciated.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20051012/93c8c6aa/attachment.html>

More information about the postgis-users mailing list