[postgis-users] Restore woes Postgres 8.0.3 / Postgis 0.9.1 to Postgres 8.1 b3 / Postgis 1.0.4 on Windows

Johan Wehtje genwolf at gmail.com
Fri Oct 21 18:06:46 PDT 2005

I have a Database that was created postgres 8.0.3 with Postgis
0.9.1(installed using PgInstaller).

I wanted to dump and restore the DB to Postgres 8.1 b3 which ships with
Postgis 1.0.4 but every option that I try fails when it comes to the spatial

I have tried running dump from the new installation , restoring into either
a DB based on Template0 or Template1 (with Postgis), but get errors about
missing dll's and functions every time. As I have all my spatial tables in
their own schema I also tried just restoring the non spatial schemas, (which
restore without complaint), and then first dumping the spatial tables to
shape files and then reloading those shapes. But the SQL Scripts also fail
on the missing GeomFromText function which appears to have undergone a name

Any suggestions as to how to upgrade without data loss?

Johan Wehtje
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20051022/05c24ecd/attachment.html>

More information about the postgis-users mailing list