[postgis-users] Problem when installing on Windows XP SP2

Mark Cave-Ayland m.cave-ayland at webbased.co.uk
Fri Mar 24 00:47:06 PST 2006

> -----Original Message-----
> From: postgis-users-bounces at postgis.refractions.net [mailto:postgis-users-
> bounces at postgis.refractions.net] On Behalf Of Lauro Bolado
> Sent: 23 March 2006 16:14
> To: postgis-users at postgis.refractions.net
> Subject: [postgis-users] Problem when installing on Windows XP SP2
> Good morning.
> My name is Lauro. I'm practically new to mapping development so i've been
> reading a book in which the main tools used for server storage of
> geographic
> information are postgreSQL and postgis.
> So I downloaded the most recent distribution of PostgreSQL for Windows on
> http://www.postgresql.org/ftp/binary/v8.1.3/win32/ and the PostGIS 1.1.1
> distribution on
> http://www.webbased.co.uk/mca/pg81/postgis-pg81-setup-1.1.1-1.exe
> For the installation I first installed PostgreSQL without the PostGIS
> contrib module. Once it was installed, I installed the PostGIS 1.1.1 that
> i
> downloaded from Mark's Development Page. This is also a double click
> installed that installs some files within the PostgreSQL main folder.
> Among
> the things installed here are the liblwgeom.dll, libgeos-2.dll,
> libgeos_c-1.dll and libproj.dll along with the utilities to convert shapes
> to pgsql and the other way around, and the sql scripts to load geographic
> functions.
> But the problem was when i tried to run those scripts. The first thing
> that
> i do is a "createlang plpgsql template1" to load the language capability
> into the template db. I get a response that it is already loaded so i
> think
> there's no problem in there. Next, i try to run the script by using "psql
> -f
> "C:\Program Files\PostgreSQL\8.1\share\contrib\lwpostgis.sql" -d
> template1"
> Here i get an error like this:
> psql:C:/Program Files/PostgreSQL/8.1/share/contrib/lwpostgis.sql:44:
> type "histogram2D" is not yet defined.
> DETAIL: Creating a shell type definition.
> psql:C:/Program Files/PostgreSQL/8.1/share/contrib/lwpostgis.sql:44:
> could not load library "C:/Program Files/PostgreSQL/8.1/lib/liblwgeom.dll"
> The specified procedure could not be found.
> And then it throws errors for every query inside the file.
> I have been looking for solutions for this problem but i haven't found
> anything. I would be deeply appreciated if you could help me on solving
> this
> cause i really want to experiment with digital maps.
> Thank you very much.
> Best regards,
> Lauro Bolado

Hi Lauro,

I have just recreated a new installation of PostgreSQL here using the 8.1.3
installer and the PostGIS 1.1.1 installer from http://www.webbased.co.uk and
it worked without any problems here on a WinXP SP2 machine.

First thing to check would be that the C:\Program
Files\PostgreSQL\8.1\lib\liblwgeom.dll file actually exists on your
computer; if you can see this file then it might be a permissions problem as
the user the PostgreSQL server runs under (normally postgres) must be able
to read this file.

Also, if you tick the "Create Database" option on the PostGIS 1.1.1
installer, can you connect to the default "dcmms" database which is created
by the installer using psql, e.g. psql -d dcmms -U postgres?

Kind regards,


WebBased Ltd
17 Research Way

T: +44 (0)1752 797131
F: +44 (0)1752 791023


This email and any attachments are confidential to the intended recipient
and may also be privileged. If you are not the intended recipient please
delete it from your system and notify the sender. You should not copy it or
use it for any purpose nor disclose or distribute its contents to any other

More information about the postgis-users mailing list