[postgis-users] Help initialize PostGIS with lwpostgis.sq l

alex_chew alex_chew at 163.com
Fri Nov 10 20:17:15 PST 2006

I am a green hand to PostGIS.Any advise will be appreciated.
Followed the tutorial, I installed PostgreSQL 8.1 with PostGIS.
It seems PostgresSQL works well, I can connect to my test database from localhost and try some querys.
Error occured when i tried to load lwpostgis.sql.Neither from pgAdmin and Commandline prompt, i got the same error message(s),
current transaction is aborted, commands ignored until end of transaction block

I tried to query some geometry data with SQL,
SELECT name, AsSVG(intersection(Simplify(the_geom,20),GeometryFromText("POLYGON((104 30,105 30,105 32,104 32,104 30))",4326)),1,1) AS svg_geom FROM river WHERE the_geom && setSRID("BOX3D(104 30, 105 32)"::box3d,4326)

Error message i got is,
ERROR:  column "POLYGON((104 30,105 30,105 32,104 32,104 30))" does not exist

Does this caused by lwpostgis.sql not loaded correctly? I am sure the table and geometry data are correctly build there. With SQL "SELECT name, AsSVG(the_geom) from river", I can get right result sets such as
("Tuolumne River";"M 255022.56361335239 -4203697.7660685452 254963.30627661903 -4203649.4423545403 ")

Please help me find out what caused the error of "POLYGON doesnot exist".
Thanks in advance.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20061111/ad32c833/attachment.html>

More information about the postgis-users mailing list