[postgis-users] Correct dump and restore

Stefan Schwarzer stefan.schwarzer at grid.unep.ch
Mon Nov 13 00:37:07 PST 2006

I added the path to the pg-bins into bash: export PATH="$PATH:/usr/ 

When I use then (for example) the psql it gives me this:

~ schwarzer$ psql geodataportal_utf8
dyld: Library not loaded: /usr/local/pgsql/lib/libpq.3.dylib
   Referenced from: /usr/local/bin/psql
   Reason: Incompatible library version: psql requires version 3.0.0  
or later, but libpq.3.dylib provides version 0.0.0
Trace/BPT trap

But if I use:

~ schwarzer$ /usr/local/pgsql/bin/psql geodataportal_utf8

everything works fine...

Any idea?


On Nov 13, 2006, at 9:07 AM, strk at refractions.net wrote:

> On Mon, Nov 13, 2006 at 07:59:14AM +0100, Stefan Schwarzer wrote:
>> Thanks for the suggestions.
>> The pg_dump works.
>> For the _restore I had to download the latest source package. But
>> because I don't do any compilations/makes I just accessed the files
>> in the download directory.
> Did it work finally ?
>> So if I run the below mentioned postgis_restore.pl command I get the
>> following error:
>> dyld: Library not loaded: /usr/local/pgsql/lib/libpq.3.dylib
>>   Referenced from: /usr/local/bin/pg_restore
>>   Reason: image not found
> If explicit pg_restore worked and postgis_restore.pl doesn't I presume
> is because postgis_restore.pl invokes the pg_restore found in path,
> which is NOT the same you were manually invoked ?
> --strk;
> _______________________________________________
> postgis-users mailing list
> postgis-users at postgis.refractions.net
> http://postgis.refractions.net/mailman/listinfo/postgis-users

More information about the postgis-users mailing list