[postgis-users] ERROR: could not load library ... liblwgeom.so.1.2

Gilles Bassière gilles.bassiere at makina-corpus.com
Tue Jul 24 09:45:48 PDT 2007

Hi list

I'm in trouble with a fresh install of postGIS 1.2.1 with postgreSQL 8.2.4

After database creation (and plpgsql language creation), I tried to load 
postgis function by issuing the command:
    psql -d netherlands -f /home/gba/apps/share/lwpostgis.sql
and I got the following error:
    psql:/home/gba/apps/share/lwpostgis.sql:43: ERROR:  could not load 
library "/home/gba/apps/lib/liblwgeom.so.1.2": libgeos_c.so.1: cannot 
open shared object file: No such file or directory

It seems to be a simple misconfiguration but...
1) libgeos_c.so.1 exists, it's located in /home/gba/apps/lib, as 
2) /home/gba/apps/lib is in LD_LIBRARY_PATH and in a conf file in 
3) I did ldconfig as root
4) Finally, ldd /home/gba/apps/lib/liblwgeom.so.1.2 
/home/gba/apps/lib/libgeos_c.so.1 ouputs the following:
        linux-gate.so.1 =>  (0xffffe000)
        libgeos_c.so.1 => /home/gba/apps/lib/libgeos_c.so.1 (0xb7f08000)
        libproj.so.0 => /home/gba/apps/lib/libproj.so.0 (0xb7ed5000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7d87000)
        libgeos.so.2 => /home/gba/apps/lib/libgeos.so.2 (0xb7c83000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7b99000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7b72000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7b66000)
        /lib/ld-linux.so.2 (0x80000000)
        linux-gate.so.1 =>  (0xffffe000)
        libgeos.so.2 => /home/gba/apps/lib/libgeos.so.2 (0xb7e21000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7d2b000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7d03000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7bc2000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7bb6000)
        /lib/ld-linux.so.2 (0x80000000)

I read several posts on this list related to library problems and tried 
the proposed solutions but I still can't get rid of that error...
Is there any known bug about Geos and PostGis, do I use the right versions ?

By the way, here is some additional information about my config
- Ubuntu 7.0.4 feisty
- postgreSQL 8.2.4 installed through apt-get
- geos 2.2.3 compiled from source
- proj 4.5.0 compiled from source

I'm stuck... Does anybody can help ?

Gilles Bassiere
30 rue des Jeuneurs
FR-75011 PARIS

More information about the postgis-users mailing list