[postgis-users] Postgis installation - Trouble with 'make check'

Bill Thoen bthoen at gisnet.com
Thu Jun 19 09:59:29 PDT 2008

I'm installing PostgreSQL, Proj4, GEOS, PostGIS, GDAL and MapServer on a 
Linux FC 9 system and  so I'm building it all from source code. I got an 
error in the 'make check' step in building PostGIS. Here's the steps I took.

Unpacked the source code into /home/postgres/postgis-1.3.3/ As postgres, 
I ran ./configure with the options I wanted.

./configure  \
  --with-pgsql=/usr/local/pgsql/bin/pg_config \
  --with-geos=/usr/local/bin/geos-config \
  --with-proj=/usr/local/ \

(this worked fine)

Then I ran make, which also appeared to work fine.

Then I ran 'make check' and got the following feedback:

make -C regress test
make[1]: Entering directory `/home/postgres/postgis-1.3.3/regress'
Creating spatial db postgis_reg
ERROR:  function postgis_lib_version() does not exist
LINE 1: select postgis_lib_version()
HINT:  No function matches the given name and argument types. You might 
need to add explicit type casts.

 Something went wrong (no postgis installed in postgis_reg).
 For details, check /tmp/pgis_reg_12582/regress_log

Looking at the log details, it seems that there's a function missing, 
and this caused the make check step to fail. The log file says:

psql:lwpostgis.sql:3856: ERROR:  could not find function 
"topologypreservesimplify" in file "/usr/local/pgsql/lib/liblwgeom.so"

Does anyone here know what went wrong and how I can fix it?

- Bill Thoen

More information about the postgis-users mailing list