[postgis-users] Postgis installation - Trouble with 'make check'

Bill Thoen bthoen at gisnet.com
Fri Jun 20 08:38:11 PDT 2008

I'm using 1.3.3 PostGIS and 3.0.0 GEOS. I built them on a freshly 
installed Fedora Core 9 system with server and desktop options fully 
loaded. As for PostgreSQL 8.3.3, Proj4.6.0, gdal 1.5.2, PostGIS 1.3.3 
and GEOS 3.0.0, none of these are updates; everything is newly installed 
on a new, freshly-formatted disc. I built geos completely as su 
(assuming that the '#' in the spartan instructions was significant), and 
I built PostGIS under the postgres user account (because I don't see how 
you can build it under any other account and run 'make check' as 
postgres as per the instructions without getting all sorts of 
'permission denied' errors).

However, there was an issue with geos during the build that may be where 
the problem lies. FC 9 now comes with gcc 4.3.0, and apparently there 
have been some changes in the include files. When I first tried to build 
GEOS, it failed with errors like 'memcpy' not defined and 'strtod' not 
defined. So I got a patch (see attached) that came from a Gentoo forum 
and applied it to the source code, and that seemed to do the trick.

But it may have introduced something that it shouldn't have, and it 
doesn't fix the errors in at least one of the test modules. If 'make 
check' for PostGIS needs one of those GEOS test modules, that may be a 
problem too. Unfortunately I have no way to tell if it's a good patch or 
a bad patch because I don't know how to read a diff file.

I'm still pretty green when it comes to building from source, so 
admittedly I'm not all that sure I know what I'm doing, but since I want 
an integrated database and map server with postgis and geos support and 
file translation support for MapInfo it seemed that my only option was 
to build everything from scratch. So it's also possible that I've made 
some mistakes.

But I think that somebody who knows the code is going to have to take a 
look at GEOS and GDAL source some time and check that it compiles with 
gcc 4.3.0 (it won't currently). And for now I've just skipped the make 
check step and went on to make install, and so far things seem to be 
working anyway (but I haven't really tested it very hard yet, either.)  
For now I'm going to move on and start populating my database, but if 
anyone has any ideas what I should try, or has any suggestions, it won't 
bother me to rebuild this all over again if I can be assured that I can 
get a flawless install. This is an experimental project at the moment 
and the machine isn't used for anything critical yet, so I'm not gripped 
about trying things on it.

- Bill Thoen

Paul Ramsey wrote:
> What GEOS are you using, Bill? Your PostGIS is mismatched to the GEOS.
> Or, at least, *something* is mismatched. Do you have old GEOS libs
> hanging around? Old postgis libs? Try really reaming out the system
> and ensure that the only things around are your new fresh builds.
> P
> On Thu, Jun 19, 2008 at 6:59 PM, Bill Thoen <bthoen at gisnet.com> wrote:
>> I'm installing PostgreSQL, Proj4, GEOS, PostGIS, GDAL and MapServer on a
>> Linux FC 9 system and  so I'm building it all from source code. I got an
>> error in the 'make check' step in building PostGIS. Here's the steps I took.
>> Unpacked the source code into /home/postgres/postgis-1.3.3/ As postgres, I
>> ran ./configure with the options I wanted.
>> ./configure  \
>>  --with-pgsql=/usr/local/pgsql/bin/pg_config \
>>  --with-geos=/usr/local/bin/geos-config \
>>  --with-proj=/usr/local/ \
>>  --with-proj-libdir=/usr/local/lib/
>> (this worked fine)
>> Then I ran make, which also appeared to work fine.
>> Then I ran 'make check' and got the following feedback:
>> make -C regress test
>> make[1]: Entering directory `/home/postgres/postgis-1.3.3/regress'
>> Creating spatial db postgis_reg
>> ERROR:  function postgis_lib_version() does not exist
>> LINE 1: select postgis_lib_version()
>>              ^
>> HINT:  No function matches the given name and argument types. You might need
>> to add explicit type casts.
>> Something went wrong (no postgis installed in postgis_reg).
>> For details, check /tmp/pgis_reg_12582/regress_log
>> Looking at the log details, it seems that there's a function missing, and
>> this caused the make check step to fail. The log file says:
>> psql:lwpostgis.sql:3856: ERROR:  could not find function
>> "topologypreservesimplify" in file "/usr/local/pgsql/lib/liblwgeom.so"
>> Does anyone here know what went wrong and how I can fix it?
>> TIA,
>> - Bill Thoen
>> _______________________________________________
>> postgis-users mailing list
>> postgis-users at postgis.refractions.net
>> http://postgis.refractions.net/mailman/listinfo/postgis-users
> _______________________________________________
> postgis-users mailing list
> postgis-users at postgis.refractions.net
> http://postgis.refractions.net/mailman/listinfo/postgis-users

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: geos-3.0.0-gcc43.patch
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20080620/ec990c26/attachment.ksh>

More information about the postgis-users mailing list