[postgis-users] shp2pgsql using problems

zhengyong zhang shieldly at gmail.com
Mon Jun 30 01:22:16 PDT 2008

when I'm trying to use shp2pgsql to convert a shp file into postgresql.
as I do it using the following commands:
1, shp2pgsql pt_gsqy_point.shp pt_gsqy_point postgis> pt_gsqy_point.sql
2, psql -d postgis -f pt_gsqy_point.sql >log.txt

after I run *the first command*, and I got sql script file:
the content is :
CREATE TABLE "pt_gsqy_point" (gid serial PRIMARY KEY,
"name" varchar(40));
SELECT AddGeometryColumn('','pt_gsqy_point','the_geom','-1','POINT',2);
INSERT INTO "pt_gsqy_point" ("name",the_geom) VALUES ('the first location
INSERT INTO "pt_gsqy_point" ("name",the_geom) VALUES ('the second location

and after *I run the second command*, in the pgadmin, I got to see the
in it. but the geometry values can not be used directly, as the values are
those : '010100000085EC6F9141E2C5C0E829EE9F0AC98240',
anyone in the mailist have used the shp2pgsql.exe???
how to deal with it, so that I can use those point coordinates to do some
operations, such as select a point using the point coordinate to get the
name of it.

yours, shieldy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20080630/bc534084/attachment.html>

More information about the postgis-users mailing list