[postgis-users] Stack Builder freezing on Windows

Jim Graham jim at nrel.colostate.edu
Fri Feb 27 13:44:20 PST 2009

Thanks for the quick reply.  I searched my system and could not find a
folder named "postgis_installer".  I tried using the "Stack Builder" from
the "start" menu and received the following error shown in SBError_1.gif.
If I click "Ignore" I receive the second error.  The log file is empty and
the installer window then freezes.

The firewall was turned off through the installation of PostgreSQL and
PostGIS.  I have not changed any of the installation or configuration files.

I just spent some time with one of our networking folks and he verified that
the port was open and PostgreSQL is listening.  We tried repeatedly with
different variations and were unable to get it to install.  One of the
errors was that a template database already existing and it could not remove
it.  We checked PostgreSQL and did not see a a template database (it was a
new install of PostgreSQL.

I was writing up this email and walking back through the installation and it
worked!  I ran the installer from the downloaded temp file
("postgis_1_3_5_pg83.exe") and without creating a spatial database.  I still
received the SBError_1 and it did create a database.  If there is a new
version of the installer I'd be happy to test it in the future (we have
other servers that are clean we could try it on).


-----Original Message-----
From: postgis-users-bounces at postgis.refractions.net
[mailto:postgis-users-bounces at postgis.refractions.net] On Behalf Of Mark
Sent: Friday, February 27, 2009 12:38 AM
To: PostGIS Users Discussion
Subject: Re: [postgis-users] Stack Builder freezing on Windows

Jim Graham wrote:

> The Stack Builder within the PostgreSQL installer locked up with a 
> screen that indicated it was checking for an existing installation of 
> PostGIS.  This was recreated on 3 machines using Windows Server 2003 
> and Windows XP.  Running the PostGIS installer separately it went 
> further and then locked up on the "Creating template database..." 
> dialog (see below).  All lockups lasted more than an hour without any 
> idication of progress.  The installer completed without locking up on a
> This was very recent with the latest builds - any ideas?
> Thanks,
> Jim

Hi Jim,

The two points at which you mention the installer freezes are when it
launches a psql (command line client) process in order to connect to your
existing PostgreSQL cluster.

If you look in your %TEMP% directory, you should find a a further directory
called postgis_installer which contains the batch files used. 
I would try and copy the content of these files and run them manually to see
what is happening from a command prompt, e.g. :

set PGPASSWORD=mypassword
set PGPORT=5432
C:\Program Files\PostgreSQL\8.3\bin\psql.exe -d template_postgis -U postgres
-h localhost -c "SELECT version();"

If there is an issue here, it should be fairly easy to spot. Have you
altered the configuration of pg_hba.conf/postgresql.conf from the installed
default? And could you have a firewall/virus checker installed blocking
connections to localhost?



Mark Cave-Ayland - Senior Technical Architect PostgreSQL - PostGIS Sirius
Corporation plc - control through freedom http://www.siriusit.co.uk
t: +44 870 608 0063
postgis-users mailing list
postgis-users at postgis.refractions.net

-------------- next part --------------
A non-text attachment was scrubbed...
Name: SBError_2.gif
Type: image/gif
Size: 12090 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20090227/66e7617a/attachment.gif>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: SBError_1.gif
Type: image/gif
Size: 11958 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20090227/66e7617a/attachment-0001.gif>

More information about the postgis-users mailing list