[postgis-users] Large leading blanks spaces in geometry column

uyen dang ruoisua at yahoo.com
Mon Oct 10 03:59:23 PDT 2011


Sorry, there are a lot of things i don't understand like :
1) how can i use ST_AsText, ST_AsEWKT, or ST_AsEWKB to get the geometry colum for raster column ?

2) what are the leading blank spaces ? because after i remove the blanks and create a raster column which this command :

INSERT INTO dummy_rast(rid, rast)
postgisdata-# VALUES (1,('01'||'0000'||'0000'||'0000000000000040'||'0000000000000840'||'000000000000E03F'||'000000000000E03F'||'0000000000000000'||'0000000000000000'||'00000000'||'0A00'||'1400')::raster),
postgisdata-# (2,('01000003009A9999999999A93F9A9999999999A9BF000000E02B274A'||'41000000007719564100000000000000000000000000000000FFFFFFFF050005000400FDFEFDFEFEFDFEFEFDF9FAFEF'||'EFCF9FBFDFEFEFDFCFAFEFEFE04004E627AADD16076B4F9FE6370A9F5FE59637AB0E54F58617087040046566487A1506CA2E3FA5A6CAFFBFE4D566DA4CB3E454C5665')::raster);

i have no error ! good , but if i run : 
SELECT rid, Box2D(rast) As rastbox FROM dummyrast;
i got : 
NOTICE:  compute_serialized_box3d called on unknown type 0 
ERROR:  lwgeom_size called with unknown-typed serialized geometry 
3) i tried to run the commannd using pgAdmin Query Tool,, but i also got :

   rid | rastbox 
    1 | 
    2 | 
    (2 rows)

i think is there anything wrong or missed while i make the installation ! 

From:Cliff Inbau <colo14ers9 at gmail.com>
To:postgis-users at postgis.refractions.net
Sent:Monday, October 10, 2011 5:37 AM
Subject:[postgis-users] Large leading blanks spaces in geometry column

When I query (using the pgAdmim Query Tool) the geometry column for some polygon tables, using ,  I am seeing "blank" values returned for many rows.    If I perform the query via SQL, there are large leading blank spaces before the actual values appear.  If I copy/paste the field value into a text editor the geometry values are actually there.  Likewise, if I display the table in Quantum GIS, the features display fine.    The geometry seems to be valid. 
I used the pgShapeFile Loader (GUI) to load the shapefiles, and no errors were displayed.

What would cause the geometry column to have these large leading blank spaces before the actual values?

Using PostGIS 1.5.3 with PostgreSQL 9.0 on Windows 7 machine.  


Cliff Inbau
colo14ers9 at gmail.com
postgis-users mailing list
postgis-users at postgis.refractions.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20111010/b55bbc46/attachment.html>

More information about the postgis-users mailing list