[postgis-users] Questions about the right uploading of raster data

Giannis Giakoumidakis ggiakoumidakis at yahoo.com
Mon Oct 17 03:46:46 PDT 2011

I have set PostGIS 2.0 with Raster (in Windows 7) and tried to upload a .tiff image, by following the instructions in 3.1 from here: http://trac.osgeo.org/gdal/wiki/frmts_wtkraster.html (python raster2pgsql.py -r /path/to/katrina.tif -t katrina -l 1 -k 64x64 -o katrina.sql -s 4326 -I -M and after psql -d <raster_database> -f katrina.sql -U <user> -W).

What i get in my database is a new table with the name of my image with no data inside (only "1" in rid serial) and a row at the raster_columns with all data  of the uploaded image except the nodata_values. I tried to import them with -n but it doesn't work with raster2pgsql.py. I connect to my database with QGIS 1.7.1 through WTKRaster plugin and what i get is no geometry and no data at all in the raster table (as expected) and the raster_columns appears as a polygon with the right coordinates but with no texture inside (only one color polygon). 

Can anyone tell what is wrong (if it is any) with this process and what to correct so I can see the raster image I upload with all the data and texture in the QGIS? I appreciate your help. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20111017/25915cf5/attachment.html>

More information about the postgis-users mailing list