[postgis-users] Questions about the right uploading of raster data

Jorge Arévalo jorge.arevalo at deimos-space.com
Tue Oct 18 05:17:50 PDT 2011

On Tue, Oct 18, 2011 at 1:45 PM, Giannis Giakoumidakis
<ggiakoumidakis at yahoo.com> wrote:
> I have one "rid" column and one "rast" column but only with one row, 1 - 0.
> So i guess the upload wasn't correct, right?

Try this query: select rid, st_astext(rast) from yourtable;

What do you see?

> I tried the command you said
> but no error messages.

After that command, did you load the resulting SQL file in your
database? The raster2pgsql command doesn't actually load the data, but
creates a SQL file that you must load in your PostGIS-enabled

I use OSGeo4W console and i have installed through
> this the GDAL 1.8.1-1. Sometimes i get a message saying: gdalinfo.exe -
> System Error "The program can't start because MSVCR90.dll is missing from
> your computer. Try reinstalling the program to fix this problem". I
> reinstalled osgeo4w but nothing changed. Maybe that's the problem? I should
> start installing dlls manually? Any other way to install gdal 1.8 without
> OSGeo4W in Windows 7 exists?

Check my post: http://gis4free.wordpress.com/2011/03/10/how-to-install-and-configure-postgis-raster-on-windows/

It may help you.

Best regards,

> ________________________________
> From: Pierre Racine <Pierre.Racine at sbf.ulaval.ca>
> To: Giannis Giakoumidakis <ggiakoumidakis at yahoo.com>; PostGIS Users
> Discussion <postgis-users at postgis.refractions.net>
> Sent: Monday, October 17, 2011 5:08 PM
> Subject: RE: [postgis-users] Questions about the right uploading of raster
> data
>> What i get in my database is a new table with the name of my image with no
>> data inside (only "1" in rid serial) and a row at the raster_columns with
>> all data
>> of the uploaded image except the nodata_values.
> You should have one "rid" column and one "rast" column. And since you loaded
> using the -k option you should have many rows in the "katrina" table.
> If this is not what you get I would suggest to replace the raster2pgsql.py
> -o option with a pipe like this:
> raster2pgsql.py -r /path/to/katrina.tif -t katrina -l 1 -k 64x64 -s 4326 -I
> -M > Katrina.sql
> to see more error message.
>> I tried to import them with -n but it doesn't work with raster2pgsql.py. I
>> connect to my database with QGIS
>> 1.7.1 through WTKRaster plugin and what i get is no geometry and no data
>> at all
>> in the raster table (as expected) and the raster_columns appears as a
>> polygon
>> with the right coordinates but with no texture inside (only one color
>> polygon).
> Before trying to display in QGIS make sure the raster was loaded properly...
> Pierre

Jorge Arévalo
Internet & Mobility Division, DEIMOS
jorge.arevalo at deimos-space.com

More information about the postgis-users mailing list