[postgis-users] Severe shapefile upload issues

Paragon Corporation lr at pcorp.us
Thu Apr 5 21:08:53 PDT 2012

Confirmed its a bug. I think it's a fairly easy one to fix so we should have
it fixed soon.

 I think it only happens if you use the new transform switch.  Can you
confirm you can import without using a transform.

I've ticketed it.  


Regarding the:

 ALTER USER postgres set search_path to public,postgis;

I would highly suggest not doing that.  The user search_path overrides the
database search_path
and it will make things hard to debug since your postgres user then may
behave differently from other users.  Since you have your db search path set
right, you shouldn't need an explicit
search path setting on the user so I would remove that setting.

ALTER ROLE postgres RESET search_path;

Hope that helps,


> -----Original Message-----
> From: postgis-users-bounces at postgis.refractions.net 
> [mailto:postgis-users-bounces at postgis.refractions.net] On 
> Behalf Of THX1138
> Sent: Thursday, April 05, 2012 10:15 PM
> To: postgis-users at postgis.refractions.net
> Subject: Re: [postgis-users] Severe shapefile upload issues
> My postgis full version is as follows:
> "POSTGIS="2.0.0 r9605" GEOS="3.3.3-CAPI-1.7.4" PROJ="Rel. 
> 4.8.0, 6 March 2012" GDAL="GDAL 1.9.0, released 2011/12/29" 
> LIBXML="2.7.8"
> My install (on Ubuntu-64 bit) could not be dirty because I 
> created a new virtual machine and built it from scratch.
> I am using  shp2pgsql and pgadmin from a windows machine (64 
> bit with 64 bit postgres and 64 bit postgis) and piping to my 
> ubuntu server. 
> On my windows machine I completely removed postgres and 
> reinstalled everything so there should be no conflict their either.
> I managed to solve the addgeometrycolumn problem by 
> impementing Bborie's suggestion (thanks btw, I would have 
> never realized that I was supposed to do that!)
> I used:
> create schema postgis;
> create extension postgis with schema postgis; create 
> extension postgis_topology; set search_path to 
> public,postgis; ALTER USER postgres set search_path to 
> public,postgis; GRANT ALL ON SCHEMA public TO postgres; GRANT 
> ALL ON SCHEMA public TO public;
> The srid conversion issue remains and I tested on both 
> windows and linux and I get the same error result... 
>  I run:
> shp2pgsql -c -s 2277:4326  -i -I "C:\tcad2\20120301_TCAD 
> postgis.mudtest4 | psql -d testing -U postgres -h -p 5432
> and get back:
> ERROR:  function st_transform(unknown, integer) is not unique 
> LINE 1: ...CH 
> MUD','4.55571330968e+007','3.22484265423e+004',ST_Transfo...
>                                                              ^
> HINT:  Could not choose a best candidate function. You might 
> need to add explicit type casts.
> I don't see how this could be a version upgrade error, 
> considering I did clean installs on both windows and ubuntu , 
> with the linux install being done on a brand new virtual 
> machine and the windows on being done using precompiled 
> binaries and installed using the batch file that came with them.
> Am I perhaps forgetting to specify an option or adding in one 
> that is incompatible? I have tried multiple shapefiles and 
> nothing works.
> --
> View this message in context: 
> http://postgis.17.n6.nabble.com/Severe-shapefile-upload-issues
> Sent from the PostGIS - User mailing list archive at Nabble.com.
> _______________________________________________
> postgis-users mailing list
> postgis-users at postgis.refractions.net
> http://postgis.refractions.net/mailman/listinfo/postgis-users

More information about the postgis-users mailing list