[postgis-users] configure error: could not find gdal

Mike Toews mwtoews at gmail.com
Wed Apr 18 01:34:50 PDT 2012

On 18 April 2012 20:32, Simon Ortet <simon.ortet at gmail.com> wrote:
> Hi,
> I'm trying to install postgis 2.0 from source and I get this error when
> running "./configure --with-pgconfig=/usr/local/pgsql/bin/pg_config":
> RASTER: Raster support requested
> checking for GDAL >= 1.6.0... found
> checking gdal.h usability... yes
> checking gdal.h presence... yes
> checking for gdal.h... yes
> checking ogr_api.h usability... yes
> checking ogr_api.h presence... yes
> checking for ogr_api.h... yes
> checking cpl_conv.h usability... yes
> checking cpl_conv.h presence... yes
> checking for cpl_conv.h... yes
> checking for library containing GDALAllRegister... no
> configure: error: could not find gdal
> I tried with "--with-gdalconfig=/usr/local/bin/gdal-config" parameter as
> well (although /usr/local/bin is in the path anyways) with the same result.
> I'm running a Debian 6.0.4 64bits.
> GDAL is installed from source and gdal-config is in the path. A "gdal-config
> --version" command returns "1.9.0"
> Could it be that my gdal is missing something? Any idea?

Your two options is to install GDAL:

sudo apt-get install libgdal-dev

Or configure without gdal:

./configure --without-raster


More information about the postgis-users mailing list