[postgis-users] PostGIS 2.0 instalation problem

Paragon Corporation lr at pcorp.us
Wed Dec 19 07:33:42 PST 2012

Well I tried it on a windows xp 32-bit.  It was running 9.1.4 2.0.0.  So
first upgraded to 2.0.1 via stackbuilder (it did give me a failure) which
was odd. Then upgraded to 9.1.7 and my 2.0.1 for some reason was fine then.
To rule out issue with a clean 9.1.7 and postgis overwriting binaries I
uninstalled 9.1.7 and postgis (whiche required reboot) , deleted the whole
PostgreSQL  folder, reinstalled 9.1.7, then 2.0.1 via stackbuilder.  All
seemed to go fine.
It's possible I have something else installed on this machine it's using,
but it does rule out XP alone being an issue.
1) Did you try rebooting your pc afterward?
2) Which service pack are you running on windows xp.
3) What virus software -- I've seen for example (I think it was Norton)
delete some postgresql files on one machine thus preventing postgresql from
Hope that helps,


From: Willy-Bas Loos [mailto:willybas at gmail.com] 
Sent: Tuesday, December 18, 2012 11:30 AM
To: PostGIS Users Discussion; Paragon Corporation
Subject: Re: [postgis-users] PostGIS 2.0 instalation problem


I have the same problem.

I installed postgres on an XP PC, which worked fine. (PostgreSQL 9.1.7,
compiled by Visual C++ build 1500, 32-bit)

Then I used the StackBuilder to install PostGIS 2.

Upon creating the extension, i get the error "ERROR: could not load library
"C:/Program Files/PostgreSQL/9.1/lib/postgis-2.0.dll": unknown error 998"

The same happens when executing the sql "create extension postgis;"

I tried pasting the contents from the bin folder from the compressed postgis
installation file into ../9.1/bin/, but to no avail.

I used Depends.exe to diagnose, like Paragon suggested.

I included the dwi-file as an attachment.

Is there anything i can do?



On Sat, May 19, 2012 at 2:50 AM, wobo <mcwobo at hotmail.com> wrote:

So, I've been trying to install PostGIS 2.0 over and over again on several
different Windows XP computers, but didn't succeed in getting it up and
running. So I ended up borrowing my brother's Windows 7 pc, using the exact
same download (postgreSQL + postgis using stackbuilder) which took me about
5 minutes to succesfully install the whole thing.

I have no clue why it doesn't work on my XP. More exactly, why it can't find
the correctly located postgis-2.0.dll-file. But at least I'll be able to
test and recap the 'PostGIS in Action' on Windows 7 from now on.

Many thanks for suggesting and helping anyway.

View this message in context:

Sent from the PostGIS - User mailing list archive at Nabble.com.
postgis-users mailing list
postgis-users at postgis.refractions.net

"Quality comes from focus and clarity of purpose" -- Mark Shuttleworth

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20121219/b8ffddb3/attachment.html>

More information about the postgis-users mailing list