[postgis-users] Topology Postgis 2.0

Sandro Santilli strk at keybit.net
Thu Sep 27 05:44:12 PDT 2012

On Thu, Sep 27, 2012 at 04:58:24AM -0700, ps.tiara wrote:
> I used PostgreSQL 9.1 and PostGIS 2.0 for PostgreSQL 9.1

When asked for a version please report the output of:

 SELECT postgis_full_version();

That way we have full information. There is 2.0.0 and 2.0.1 of PostGIS.

> I tried in two ways..
> FIRST, I populated geometry to the schema using CreateTopoGeo, and then

Great, it looks like it worked.

> updated 
> the topology column using CreateTopoGeom... (the query and data attached)

I fail to understand your CreateTopoGeom query in there.
Did you try toTopoGeom as a replacement of CreateTopoGeo and CreateTopoGeom ?

> but when i visualized the result of topology in x3d, it was mess..maybe i
> made a mistake by wrong query??

How did you visualize ? What do you mean by "messy" ?
The topology in your backup results valid, and I can see it just fine.
But yes, I do see a lot of very small faces, a lot of edges close 
to one other.

Maybe you should try to specify a tolerance when creating the topology.
Did you try that ?

> SECOND, i tried to update the topology column using toTopoGeom..but
> this not succeeded..the query and the message error as below
> UPDATE simpanglima.ruang
> SET ruang_topo = topology.toTopoGeom(ruang_geom,'simpanglima_topo',3)
> WHERE rid='1';
> ERROR:  function topogeo_addpolygon(unknown, geometry, numeric) does not
> exist
> LINE 1: ...yer_id, element_type, element_id) SELECT 5, 3, 3, topogeo_ad...

Sounds like a bug which got fixed in 2.0.1.
You can work around it by adding "topology" to your search path.

  search_path to <output_from_previous_query>, topology


 http://www.cartodb.com - Map, analyze and build applications with your data

                                       ~~ http://strk.keybit.net 

More information about the postgis-users mailing list