[postgis-users] Topology Postgis 2.0

ps.tiara ps.tiara at yahoo.com
Thu Sep 27 04:58:24 PDT 2012

I used PostgreSQL 9.1 and PostGIS 2.0 for PostgreSQL 9.1

I tried in two ways..
FIRST, I populated geometry to the schema using CreateTopoGeo, and then
the topology column using CreateTopoGeom... (the query and data attached)
but when i visualized the result of topology in x3d, it was mess..maybe i
made a mistake by wrong query??

SECOND, i tried to update the topology column using toTopoGeom..but
this not succeeded..the query and the message error as below

UPDATE simpanglima.ruang
SET ruang_topo = topology.toTopoGeom(ruang_geom,'simpanglima_topo',3)
WHERE rid='1';

ERROR:  function topogeo_addpolygon(unknown, geometry, numeric) does not
LINE 1: ...yer_id, element_type, element_id) SELECT 5, 3, 3, topogeo_ad...
HINT:  No function matches the given name and argument types. You might need
to add explicit type casts.
QUERY:  INSERT INTO simpanglima_topo.relation(topogeo_id, layer_id,
element_type, element_id) SELECT 5, 3, 3,
CONTEXT:  PL/pgSQL function "totopogeom" line 129 at EXECUTE statement

Which one is the best methode to complete my research?
Many thanks..


View this message in context: http://postgis.17.n6.nabble.com/Topology-Postgis-2-0-tp5000006p5000052.html
Sent from the PostGIS - User mailing list archive at Nabble.com.

More information about the postgis-users mailing list