[postgis-users] [GENERAL] Error During PostGIS Build From Source on Linux

Regina Obe lr at pcorp.us
Sat Apr 15 20:52:50 PDT 2017



That error means you have installed an older version of GEOS in your system and it's picking up the old one instead of the one in your




I suspect that's the same issue with your proj too.


I think doing an ldconfig after install of GEOS and proj might fix the issue, but I forget.


It's been a while since I've had to compile the extra dependencies even if building PostGIS on Linux.


Regarding the whole GDAL thing on windows.


I'm the builder of the Windows application Stackbuilder PostGIS bundle and also manage the Windows PostGIS buildbot.


As I think someone mentioned, as a policy we don't compile any proprietary extensions into the distributed windows PostGIS bundle.

So that's one reason why Mr. SID is not included and will probably never be included.


However, you could convert Mr. SID format to something like OpenJpeg or TIFF using GISInternals GDAL binaries for windows:




Last I tried, that one does have Mr. SID support.  Unfortunately you can't swap out his GDAL for the ones we package.

I was hoping I could make that possible at some point, but no free time or enough funding interest to investigate.



Regina Obe

PostGIS PSC member





From: postgis-users [mailto:postgis-users-bounces at lists.osgeo.org] On Behalf Of Osahon Oduware
Sent: Friday, April 14, 2017 3:21 PM
To: Adrian Klaver <adrian.klaver at aklaver.com>
Cc: pgsql-general at postgresql.org; PostGIS Users Discussion <postgis-users at lists.osgeo.org>
Subject: Re: [postgis-users] [GENERAL] Error During PostGIS Build From Source on Linux


Hi Adrian,


I installed Proj from source and I can confirm that the file libproj.so.12 is in its lib folder.


I have not been able to confirm if it is linked to  <http://postgis-2.3.so/> postgis-2.3.so as I am away for Easter holiday.


Just in case, how do I do the linking of libproj.so.12 to  <http://postgis-2.3.so/> postgis-2.3.so as I believe this could be the cause of the error. Also, I tried earlier to copy the file to the PostgreSQL lib folder and this time when I try to run "CREATE EXTENSION postgis;" I get the initial error:

ERROR: could not load library "/path/to/postgresql/lib/ <http://postgis-2.3.so/> postgis-2.3.so": /path/to/postgresql/lib/ <http://postgis-2.3.so/> postgis-2.3.so: undefined symbol: GEOSClipByRect


I will be glad if anyone could help with this.


On Apr 13, 2017 18:27, "Adrian Klaver" <adrian.klaver at aklaver.com <mailto:adrian.klaver at aklaver.com> > wrote:

On 04/13/2017 07:54 AM, Osahon Oduware wrote:

Hi Adrian,

Thanks for your help so far. This is the output of the PostGIS

-------------- Compiler Info -------------
  C compiler:           gcc -g -O2
  SQL preprocessor:     /usr/bin/cpp -traditional-cpp -w -P

 -------------- Dependencies --------------
  GEOS config:          /home/nagispg/local/geos361/bin/geos-config
  GEOS version:         3.6.1
  GDAL config:          /home/nagispg/local/gdal213/bin/gdal-config
  GDAL version:         2.1.3
  PostgreSQL config:    /home/nagispg/local/pgsql/bin/pg_config
  PostgreSQL version:   PostgreSQL 9.6.2
  PROJ4 version:        49
  Libxml2 config:       /usr/bin/xml2-config
  Libxml2 version:      2.7.6
  JSON-C support:       no
  PCRE support:         no
  PostGIS debug level:  0
  Perl:                 /usr/bin/perl

 --------------- Extensions ---------------
  PostGIS Raster:       enabled
  PostGIS Topology:     enabled
  SFCGAL support:       disabled
  Address Standardizer support:       disabled

 -------- Documentation Generation --------
  xsltproc:             /usr/bin/xsltproc
  xsl style sheets:
  convert:              /usr/bin/convert
  mathml2.dtd:          http://www.w3.org/Math/DTD/mathml2/mathml2.dtd

I had to install a *higher version of Proj (4.9.3)* that was used to

configure PostGIS (I think I read somewhere in the documentation that

the version of Proj should be >= 4.6.0). *Now, I get the following error
when I run CREATE EXTENSION postgis:*

How did you install Proj, from a package or source?

*ERROR: could not load library postgis-2.3.so <http://postgis-2.3.so>  <http://postgis-2.3.so>:
libproj.so.12: cannot open shared object file: No such file or directory*

First find postgis-2.3.so <http://postgis-2.3.so>  and do:

ldd postgis-2.3.so <http://postgis-2.3.so> 

It should show something like:

        linux-vdso.so.1 (0x00007ffe3ed8a000)
        libgeos_c.so.1 => /usr/lib64/libgeos_c.so.1 (0x00007f975bd09000)
    ==> libproj.so.9 => /usr/lib64/libproj.so.9 (0x00007f975baaa000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00007f975b73f000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f975b442000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f975b09e000)
        libgeos-3.5.1.so <http://libgeos-3.5.1.so>  => /usr/lib64/libgeos-3.5.1.so <http://libgeos-3.5.1.so>  (0x00007f975acef000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f975a966000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f975a74e000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f975a531000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f975a32d000)
        libz.so.1 => /lib64/libz.so.1 (0x00007f975a116000)
        liblzma.so.5 => /usr/lib64/liblzma.so.5 (0x00007f9759eed000)
        /lib64/ld-linux-x86-64.so.2 (0x000055ebafa02000)

That will verify if postgis-2.3.so <http://postgis-2.3.so>  is linked to libproj.

I would be glad if someone could point me to what I am doing wrong and
possible solution.


Adrian Klaver
adrian.klaver at aklaver.com <mailto:adrian.klaver at aklaver.com> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20170415/07eda390/attachment.html>

More information about the postgis-users mailing list