[postgis-users] Raster Table Name With Upper-Case Characters

Osahon Oduware osahon.gis at gmail.com
Fri Jul 14 05:27:16 PDT 2017

Hi Mateusz,

I have just tried using the -q option and it works. Thanks a lot. I have
gone through the doc a lot to resolve several issues in the past. In this
case it was an oversight as I thought that explicitly wrapping the
identifiers in quote would give the same result as the -q option.

On Fri, Jul 14, 2017 at 12:10 PM, Mateusz Loskot <mateusz at loskot.net> wrote:

> On 14 July 2017 at 12:44, Osahon Oduware <osahon.gis at gmail.com> wrote:
> >
> > Thanks for your suggestion. I would attempt this on a small raster and
> give
> > you feedback. However, in practice I am working with a large raster,
> hence,
> > I am piping the output of the raster2pgsql command with the connection to
> > the database as below:
> > raster2pgsql -s <SRID> -d -Y -e -I -C -F -M /path/to/raster/file
> > <RASTER_TABLE> | psql -h localhost -U postgres -p 5432 -d <database>
> >
> If you scanned the docs you would have learned about -q option.
> (reading PostgreSQL docs on quoted identifiers might be useful too).
> If quoted identifiers are not requested, raster2pgsql forces database
> object names (schema/table...) to lowercase.
> Best regards,
> --
> Mateusz Loskot, http://mateusz.loskot.net
> _______________________________________________
> postgis-users mailing list
> postgis-users at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/postgis-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20170714/af5b7088/attachment.html>

More information about the postgis-users mailing list