[postgis-users] [EXTERNAL] Re: PostGIS on Centos 7

Lars Aksel Opsahl Lars.Opsahl at nibio.no
Wed Apr 25 20:51:56 PDT 2018


On CentOS Linux release 7.4.1708 (Core)  this worked without any problems a couple of weeks ago.

yum install https://download.postgresql.org/pub/repos/yum/10/redhat/rhel-7-x86_64/pgdg-centos10-10-2.noarch.rpm
yum install postgresql10 postgresql10-server postgis24_10 postgis24_10-utils.x86_64 postgis24_10-client.x86_64

The gdal packages was installed by default by the commands above

gdal-doc-1.11.4-12.rhel7.noarch               Tue 03 Apr 2018 07:40:49 AM CEST
gdal-python-1.11.4-12.rhel7.x86_64            Tue 03 Apr 2018 07:39:40 AM CEST
gdal-1.11.4-12.rhel7.x86_64                   Tue 03 Apr 2018 07:39:40 AM CEST
gdal-perl-1.11.4-12.rhel7.x86_64              Tue 03 Apr 2018 07:39:39 AM CEST
gdal-devel-1.11.4-12.rhel7.x86_64             Tue 03 Apr 2018 07:39:39 AM CEST
gdal-libs-1.11.4-12.rhel7.x86_64              Tue 03 Apr 2018 07:38:49 AM CEST

Installed on kernel 3.19 changed to kernel 4.16 last week.


Fra: postgis-users <postgis-users-bounces at lists.osgeo.org> på vegne av Bryan Hall <bryan.hall at chk.com>
Sendt: 25. april 2018 23:17
Til: PostGIS Users Discussion
Emne: Re: [postgis-users] [EXTERNAL] Re:  PostGIS on Centos 7


Do you have a cheat-sheet for installation of both PostgreSQL and PostGIS with all the required extensions?

I'm actually installing it onto OEL 7 AKA "Red Hat Enterprise Linux Server release 7.4 (Maipo)", and have tried to follow the following guide to getting this all working. As they say, close but no cigar. Possibly because of version differences, but I'm not sure as this is the first time I've tried to do it from scratch.


After downloading and making, installing all the dependencies (including GDAL), when trying to add postgis:

sudo yum install postgis2_10 postgis2_10-client

I get:

--> Finished Dependency Resolution
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libarmadillo.so.8()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libfreexl.so.1()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libCharLS.so.1()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libopenjp2.so.7()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libnetcdf.so.7()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libcfitsio.so.2()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libdap.so.17()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libhdf5.so.8()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libdapserver.so.7()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libgta.so.0()(64bit)
Error: Package: gdal-libs-1.11.4-12.rhel7.x86_64 (pgdg10)
           Requires: libdapclient.so.6()(64bit)
Error: Package: postgis24_10-2.4.4-1.rhel7.x86_64 (pgdg10)
           Requires: hdf5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I don't understand why that is. Can postGIS not use GDAL 2.2.4 libs?



-----Original Message-----
From: postgis-users [mailto:postgis-users-bounces at lists.osgeo.org] On Behalf Of Phil Hurvitz
Sent: Wednesday, April 25, 2018 14:07
To: PostGIS Users Discussion <postgis-users at lists.osgeo.org>
Subject: [EXTERNAL] Re: [postgis-users] PostGIS on Centos 7

I have been using PostGIS without complaint for quite some time on Centos 7 using the community packages.


Philip M. Hurvitz, PhD | Research Assistant Professor | UW-CBE Urban Form Lab  | 1107 NE 45th Street, Suite 535  | Box 354802 University of Washington, Seattle, Washington  98195-4802, USA phurvitz at u.washington.edu | https://urldefense.proofpoint.com/v2/url?u=http-3A__gis.washington.edu_phurvitz&d=DwIGaQ&c=M7nMI6M-Uv3ihEfN-QJ3_sQdVexoO64eU4Ftr4lnVk0&r=-89XSUoV_kZKlHf89FQGuyqPyUjA53juyA-7r7GoZVA&m=cjKf86G4uPnnLqLkgUEz_WM5sLnNhPYUt_f-tlA6TBc&s=wzInbtqEu5E28kzPyg0LTPBsH25ihh2uIMoXMZ40ZDo&e=
"What is essential is invisible to the eye." -de Saint-Exupéry

On 2018-04-25 12:00, postgis-users-request at lists.osgeo.org wrote:
> Message: 1
> Date: Wed, 25 Apr 2018 16:09:31 +0100
> From: Mark Jackson <mark.jackson at cerc.co.uk>
> To: postgis-users at lists.osgeo.org
> Subject: [postgis-users] PostGIS on Centos 7
> Message-ID: < at cerc.co.uk>
> Content-Type: text/plain; charset="us-ascii"; format=flowed
> Hi there
> We have a managed server with PostGreSQL / PostGIS and Centos. We
> asked our ISP about moving to a new server and they said PostGIS
> "would not work well with CentOS7, certainly not without a great deal
> of customisation and it's something we would not recommend. " (I am
> not convinced they know much about PostGIS  though...)
> Does PostGIS  work well on Centos 7?
> Is there a web page that says PostGIS  works well on Centos 7 - so I
> can send it to the ISP ?
> Back in 2011 the same ISP installed PostgreSQL 9.0.2 with PostGIS
> onto Centos 5 fairly easily. I don't know exactly why they are
> reluctant to install PostGIS  on Centos 7 - they have not given
> details. We would be happy to use the most up-to-date Postgresql and PostGIS.
> (I'm reluctant to shift to another ISP because up to now, these guys
> have been excellent. I'd like to convince them that PostGIS is fine on
> Centos 7.)
> Thanks
> Mark
> **********************************************************************
> ********************* Cambridge Environmental Research Consultants
> Ltd. cannot accept any responsibility for the accuracy or completeness
> of this message as it has been transmitted over a public network.
> This e-mail and any files transmitted with it are private and intended
> solely for the use of the individual or entity to whom they are
> addressed. If you are not the intended recipient, this e-mail and any
> accompanying files have been transmitted to you in error.  You may not
> copy, distribute or make any other use of the information contained in
> them.
> CERC is a trading name of Cambridge Environmental Research Consultants
> Ltd, registered at Cardiff with number 1926883. Registered Office address:
> 3 Kings Parade, Cambridge, CB2 1SJ.
postgis-users mailing list
postgis-users at lists.osgeo.org


This email (and attachments if any) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is confidential or privileged and exempt from disclosure under applicable law. If the reader of this email is not the intended recipient, or the employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by return email and destroy all copies of the email (and attachments if any).
postgis-users mailing list
postgis-users at lists.osgeo.org

More information about the postgis-users mailing list