[postgis-users] How to install the latest PostGIS (3.0 or very latest) on CentOS 8.1?

/dev /local/ca devlocalca at gmail.com
Thu Apr 30 00:35:59 PDT 2020

I am attempting to following instructions to install PostGIS here (to
install the latest production release of PostGIS on CentOS 8.1):



In the section titled:
`Red Hat / Centos / Scientific Linux`
I do not understand exactly what it is I need to do there, or if I need to
do it,or how to determine if I need to do anything in that section.


When I run this command on my CentOS 8 system,

`$dnf list | grep postgis30_12`

I get:

postgis30_12.x86_64                                  3.0.1-2.rhel8
postgis30_12-client.x86_64                           3.0.1-2.rhel8
postgis30_12-devel.x86_64                            3.0.1-2.rhel8
postgis30_12-docs.x86_64                             3.0.1-2.rhel8
postgis30_12-gui.x86_64                              3.0.1-2.rhel8
postgis30_12-utils.x86_64                            3.0.1-2.rhel8


*Question 1:*
so therefore, is there anything in that section that I need to do?

*Question 2:*
After reading this section, how would I determine if I need to do anything?

*Question 3:*
And if so, what would that be?


*When I run:*

`create extension postgis;`

*I get this error:*

ERROR:  could not open extension control file
"/usr/pgsql-12/share/extension/postgis.control": No such file or

When checking, indeed that file (*postgis.control*) is not there.

*Question 4:*

What am I missing?


*sql>select version();`*

PostgreSQL 12.2 on x86_64-pc-linux-gnu, compiled by gcc (GCC) 8.3.1
20190507 (Red Hat 8.3.1-4), 64-bit


OS installed was: *CentOS Linux release 8.1.1911* (Core)

(not sure why it says: Red Hat 8.3.1-4 in: select version();)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20200430/c1d5c76e/attachment.html>

More information about the postgis-users mailing list