[postgis-users] dump and restore

Regina Obe lr at pcorp.us
Thu Jun 18 10:18:21 PDT 2020

You are probably installing into a newer version of PostGIS is my guess and
PostGIS 3+ now has postgis_raster as a separate extension.

Your restore only has CREATE EXTENSION postgis;  so would be missing the
postgis_raster bit.


If you need raster support, you should do 


create newdb


In you newdb database run



CREATE EXTENSION postgis_raster;



Then follow with your restore


From: postgis-users [mailto:postgis-users-bounces at lists.osgeo.org] On Behalf
Of Crawford Jr., Stephen Rand
Sent: Thursday, June 18, 2020 11:57 AM
To: postgis-users at lists.osgeo.org
Subject: [postgis-users] dump and restore




I have a postGIS database that I am moving to a new machine.  I tried these
forms of dump and restore, which have worked on other databases:


pg_dump -Fc db > db.dump


createdb newdb


pg_restore -v -d newdb db.dump


But for this database restore hangs on the first table, which is full of
rasters, as are most of the tables in this database.  Are there any other
flags or techniques that I should be using?





Stephen Crawford

Center For Environmental Informatics

The Pennsylvania State University

src176 at psu.edu <mailto:src176 at psu.edu> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20200618/d38b5cd9/attachment.html>

More information about the postgis-users mailing list