[postgis-users] PostGIS functions not working on AWS via Lambda function

Alexander Gataric gataric at usa.net
Tue Mar 17 07:37:59 PDT 2020

I get the same error message as if PostGIS isn't installed. Function not found error.

I'm invoking in lambda via python code like this:

import boto3
import psycopg3

def lambda_handler(event,lambda_context)

# login and connection stuff

cur.execute("select * from schema.udf_name (parm1,parm2)")

The UDF invokes several PostGIS functions such as st_dwithin.

⁣Get BlueMail for Android ​

On Mar 17, 2020, 9:04 AM, at 9:04 AM, Giuseppe Broccolo <g.broccolo.7 at gmail.com> wrote:
>Hi Alexander,
>can you add further details (snippet of code, etc.) about this?
>Never tried doing this, but AFAIK AWS lambda runs on preconfigured RDS
>maybe it's just enough to include the CREATE EXTENSION.
>Il giorno mar 17 mar 2020 alle ore 12:55 Alexander Gataric
><gataric at usa.net>
>ha scritto:
>> I'm trying to create a service to invoke Postgres UDFs that utilize
>> functions via an AWS lambda function. The error I get is as if the
>> extension is not installed. Has anyone encountered this before?
>> Thanks
>> Alex
>> _______________________________________________
>> postgis-users mailing list
>> postgis-users at lists.osgeo.org
>> https://lists.osgeo.org/mailman/listinfo/postgis-users
>postgis-users mailing list
>postgis-users at lists.osgeo.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20200317/562af35d/attachment.html>

More information about the postgis-users mailing list