[postgis-users] Fwd: Re: Broken installs for PostGIS for Ubuntu 20.04LTS / Focal?

Tom van Tilburg tom.van.tilburg at gmail.com
Wed May 13 11:45:17 PDT 2020

I just had the time to try a postgis install but reached to a different
result of missing libCGAL.
Here's my setting:

Yesterday upgraded to Focal

- Added apt repo for postgres.
- Installed postgres-12 and postgis
- Tried to do 'CREATE EXTENSION postgis':
ERROR:  could not load library "/usr/lib/postgresql/12/lib/postgis-3.so":
libCGAL_Core.so.13: cannot open shared object file: No such file or

I tried to manually install libcgal but this doesn't appear to be available
for focal yet.
See: https://packages.ubuntu.com/search?keywords=cgal

The sfcgal library used by postgis is available though:
% sudo dpkg --list |grep cgal
ii  libcgal-dev:amd64                          5.0.2-3
          amd64        C++ library for computational geometry (development
ii  libsfcgal1                                 1.3.7-4ubuntu3
         amd64        Library for ISO 19107:2013 and OGC SFA 1.2 for 3D

Your email has a curious parallel to my installation attempt of qgis though
which ended at:
Setting up qgis-providers (1:3.12.2+32focal) ...
/usr/lib/qgis/crssync: symbol lookup error: /usr/lib/libgdal.so.26:
undefined symbol:
Leaving me with an invalid setup of dpkg (only clears after uninstalling

All in all, it seems the packages are in an incomplete state currently.


On Wed, May 13, 2020 at 3:15 PM Marco Boeringa <marco at boeringa.demon.nl>

> Thanks Tom,
> I have seen a similar error related to the "libgdal26" library, but that
> was after other trials to get something running on Ubuntu 20.04 Focal,
> where I successfully installed PostGIS 2.5.4, but then encountered issues
> when my code called the "postgis_full_version()" function and errored out
> with the error message below related to the "libgdal.so.26" library.
> However, as said, this was with PostGIS 2.5.4, not with the PostGIS 3.0.1 I
> actually want to install at this moment and that gave the other error
> related to the "postgis-3.so" library.
> SQL Error [XX000]: ERROR: could not load library
> "/usr/lib/postgresql/11/lib/rtpostgis-2.5.so": /usr/lib/libgdal.so.26:
> undefined symbol: GEOSMakeValid_r
>   Where: SQL statement "SELECT public.postgis_gdal_version()"
> PL/pgSQL function postgis_full_version() line 34 at SQL statement
> Marco
> Sorry for the short answer, am on the way currently. Will try to do a
> decent report tonight.
> Error is roughly the same but comes from libgdal26 in my case when doing
> apt install qgis after an upgrade to 20.04.
> best, Tom
> On Wed, 13 May 2020, 14:48 Marco Boeringa, <marco at boeringa.demon.nl>
> wrote:
>> Thanks for the response Tom, but could you be a bit more specific?
>> What do you mean with "Same problem with qgis"? Do you mean you've also
>> encountered a "undefined symbol: GEOSMakeValid" error related to the
>> "postgis-3.so" library when trying to use some tool in QGIS?
>> I have installed PostgreSQL 12 and PostGIS 3.0.1 via Synaptic on Ubuntu
>> 20.04 (Focal) and use CREATE EXTENSION (via pgAdmin4), when I encounter the
>> error.
>> Marco
>> Op 13-5-2020 om 14:40 schreef Tom van Tilburg:
>> Same problem with qgis
>> On Wed, 13 May 2020, 11:14 Marco Boeringa, <marco at boeringa.demon.nl>
>> wrote:
>>> Hi all,
>>> Is there someone who can confirm they have been able to install PostGIS
>>> 3.0.1 via the official APT repository?:
>>> https://wiki.postgresql.org/wiki/Apt
>>> After using the Synaptics Package Manager to install the three packages
>>> involved
>>> ("postgresql-12-postgis-3"/"postgresql-12-postgis-3-dbgsym"/"postgresql-12-postgis-3-scripts"),
>>> and subsequently trying to create the PostGIS extension in pgAdmin4, I
>>> get the following error:
>>> ERROR: could not load library "/usr/lib/postgresql/12/lib/postgis-3.so":
>>> /usr/lib/postgresql/12/lib/postgis-3.so: undefined symbol: GEOSMakeValid
>>> I have been trying different things to fix this for past two days
>>> including re-install, but to no avail. I have also attempted to include
>>> the UbuntuGIS repository as a potential alternative resource of PostGIS
>>> packages, but discovered the UbuntuGIS repository is lagging behind and
>>> doesn't yet have packages for 20.04LTS.
>>> Marco
>>> _______________________________________________
>>> postgis-users mailing list
>>> postgis-users at lists.osgeo.org
>>> https://lists.osgeo.org/mailman/listinfo/postgis-users
>> _______________________________________________
>> postgis-users mailing listpostgis-users at lists.osgeo.orghttps://lists.osgeo.org/mailman/listinfo/postgis-users
>> _______________________________________________
> postgis-users mailing list
> postgis-users at lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/postgis-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/postgis-users/attachments/20200513/b86f40a8/attachment.html>

More information about the postgis-users mailing list