[Qgis-developer] dep trouble with feisty packages

Matthew Perry perrygeo at gmail.com
Wed Oct 17 00:05:04 EDT 2007

On 10/16/07, icosa atropa <icos.atropa at gmail.com> wrote:
> Tim,
> I tried installing feisty packages from
> http://qgis.org/uploadfiles/testbuilds/, but I'm still getting
> problems with deps.
> I first did a fresh apt-get update/upgrade/dist-upgrade prior to
> installing debs.  Still, I get stuck on libqgis1 with the following:
> xian at wrp:/usr/local/src$ sudo dpkg -i libqgis1_0.9.0_i386.deb
> Selecting previously deselected package libqgis1.
> (Reading database ... 71051 files and directories currently installed.)
> Unpacking libqgis1 (from libqgis1_0.9.0_i386.deb) ...
> dpkg: dependency problems prevent configuration of libqgis1:
>  libqgis1 depends on libqt4-core (>= 4.3.0); however:
>   Version of libqt4-core on system is 4.2.3-0ubuntu3.

Try adding the backports repository which should have qt4.3 :

deb http://us.archive.ubuntu.com/ubuntu/ feisty-backports main
restricted universe multiverse

Keep in mind that the recent pyqt-dev-tools (pyuic, etc) have not been
backported to feisty so if you're planning on doing any gui
development work with python and qt, you'll have to tread carefully.

- matt

>  libqgis1 depends on libqt4-gui (>= 4.3.0); however:
>   Version of libqt4-gui on system is 4.2.3-0ubuntu3.
>  libqgis1 depends on libqt4-qt3support (>= 4.3.0); however:
>   Version of libqt4-qt3support on system is 4.2.3-0ubuntu3.
> dpkg: error processing libqgis1 (--install):
>  dependency problems - leaving unconfigured
> Errors were encountered while processing:
>  libqgis1

Matthew T. Perry

"Never ascribe to malice, that which can be adequately explained by

More information about the Qgis-developer mailing list