[Qgis-developer] Build compile error

volkan kepoglu vkepoglu at gmail.com
Mon Jan 21 06:47:41 EST 2008

Thanks alot. it worked. I build QGIS from source code.

I don't know previously why it doesn't work. it maybe difference between the
package installed with sudo apt-get install libgeos-dev whose version is
2.3.3-3 as stated in snaptic package manager and source code of geos-2.3.3.

I am getting the following error in idle 1.2.1 of python 2.5.1

>>> from PyQt4.QtCore import *
>>> from PyQt4.QtGui import *
>>> from qgis.core import *
Traceback (most recent call last):
  File "<pyshell#2>", line 1, in <module>
    from qgis.core import *
ImportError: No module named qgis.core

I have tried to define the path as follows, in order to try all

export PYTHONPATH=/usr/local/share/qgis/python

but nothing changed. the same error in python. module couldn't find.

I do not know which path to define. in ccmake I accepted all default paths.
what actually do these paths? is it required to define these paths for each
session, I mean when ı closed the terminal, path assignment is disappearing.

should ı define ld_library_path as the path of source code:

should I re-build by setting BINDINGS_GLOBAL_INSTALL variable in CMake to

maybe I should define in which path to install qgis, isn't it?
but do not know how to define
is CMAKE_BUILD_PREFIX (is it the path definition of installing qgis) the
equilavent of CMAKE_INSTALL_PREFIX, because in ccmake version 2.4 there is

On 1/20/08, Martin Dobias <wonder.sk at gmail.com> wrote:
> On Jan 20, 2008 4:06 PM, volkan kepoglu <vkepoglu at gmail.com> wrote:
> >
> >
> > I am trying to build QGIS from source code in Ubuntu 7.10 Gutsy Gibbon,
> but
> > I couldn't. I followed the instructions in the wiki page
> buildingFromSource.
> > The following error has occurred. I think it is about GEOS. installed
> > version of libgeos-dev is 2.2.3-3.
> I use GEOS 2.2.3 from ubuntu 7.10 with no problems.
> >  so, I build geos-3.0.0. and pedantic option is off in ccmake by
> default.
> > However following error is occurred;
> >
> >
> >
> >
> > In file included from /usr/local/include/geos.h:27,
> >
> >  from /home/vkepoglu/dev/cpp/qgis/src/core/qgsgeometry.h:26,
> >
> >  from /home/vkepoglu/dev/cpp/qgis/python/core/qgsgeometry.sip:21:
> >
> > /usr/local/include/geos/geom.h:145:2: warning: #warning *** DEPRECATED:
> You
> > are using deprecated header geom.h. Please, update your sources
> according to
> > new layout of GEOS headers and namespaces
> Actually this is not an error, just a warning...
> Martin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/qgis-developer/attachments/20080121/0a9aad86/attachment.html

More information about the Qgis-developer mailing list