[Qgis-developer] Re: Qgis app bundle script

William Kyngesburye woklist at kyngchaos.com
Thu Jun 19 18:17:12 EDT 2008

(back to the list to get others in on the discussion)

Once I got the right geoprocessing plugin installed (not the builtin  
pggeoprocessing), I could test this.  Indeed, in an unmodified build  
the Qgis Python console starts, but in the geoprocessing plugin, no  
layers are available to choose, even when there are layers in the  

I then changed one thing: I "fixed" the library paths in core.so and  
gui.so to use the @executable_path relative path (fixing the source  
path as installed, and instead of the @loader_path that I use in my  
builds).  Then it worked, I successfully created a buffer.

This is with both a Leopard build on Leopard, using the system Python  
2.5, and a Tiger build on Tiger, suing the python.org python 2.5.

But, what about the all-in-one Qgis build?  It has @executable_path in  
core.so and gui.so.  I wonder if it's a Python version problem - the  
all-in-one Qgis is built to use the Tiger system Python 2.3, not the  
python.org Python 2.5.  Though the Qgis python console starts, maybe  
the plugins need a more recent Python?

While the Python 2.5 in the Leopard system is a very usable build of  
Python, Apple's Python 2.3 in Tiger is generally regarded as unusable  
for anything serious.  Maybe the all-in-one build whould at least have  
one external requirement: Python 2.5?

On Jun 18, 2008, at 10:17 PM, John C. Tull wrote:

> Thanks again, William. I'll look forward to hearing your results and  
> input.
> John
> On Jun 18, 2008, at 8:03 PM, William Kyngesburye wrote:
>> I've only tried one python plugin so far - manageR, back in May.   
>> I'll take a look at others and try one in a 'raw' build and see  
>> what I get.
>> PS. Tim - are there plans to move Qgis python plugins out of  
>> ~/.qgis (for OSX)?  Maybe ~/Library/Application Support/Qgis?  I  
>> also have an old 'qgis.db' file in ~/.qgis from 2006, but I don't  
>> know if it's used any more.
>> On Jun 18, 2008, at 9:56 PM, John C. Tull wrote:
>>> William,
>>> Just getting to today's email...
>>> The problem is not with getting Python bindings or the console  
>>> working, instead it is with various plugins that attempt to query  
>>> layers from the map canvas. When I install the geoprocessing  
>>> plugin with your 0.10 build, I get a functional plugin that loads  
>>> layers in the drop-down menu list. For my builds, this does not  
>>> populate, so the python plugins are useless.
>>> It must have something to do with your linking repairs post-build.  
>>> I would assume a script to run those changes that works for anyone  
>>> using your frameworks to build qgis from source would end up with  
>>> a binary that functions properly wrt python plugins.
>>> Thanks,
>>> John

William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>

All generalizations are dangerous, even this one.

More information about the Qgis-developer mailing list