[Qgis-developer] My introduction and 1st question

Stefan Sassenberg stefan.sassenberg at gmx.de
Fri Sep 5 15:37:08 EDT 2008


I'm Stefan. I recently downloaded qgis to see if I could use it for my 
needs. I think it is, but there's still something missing that I need. 
Ok, I just might not have found it yet, but anyway I considered it a 
good idea to have a look at the source code to see if I should spend 
some time to make this or that modification. Until then I worked on my 
own Java application for importing and exporting tracks, waypoints and 
routes to and from my eTrex (in fact it does a lot more, I'd feel little 
sad to give it all up).

I checked out qgis with "svn co https://svn.osgeo.org/qgis/trunk/qgis 
qgis" and configured it successfully. "Making" the current state is yet 
not possible, because of an error:

/home/stefan/cprg/workspace/qgis/src/core/qgsgeometry.cpp: In member 
function »int QgsGeometry::splitLinearGeometry(GEOSGeom_t*, 
/home/stefan/cprg/workspace/qgis/src/core/qgsgeometry.cpp:4602: Fehler: 
»GEOSLength« wurde in diesem Gültigkeitsbereich nicht definiert
/home/stefan/cprg/workspace/qgis/src/core/qgsgeometry.cpp: In member 
function »int QgsGeometry::splitPolygonGeometry(GEOSGeom_t*, 
/home/stefan/cprg/workspace/qgis/src/core/qgsgeometry.cpp:4693: Fehler: 
»GEOSArea« wurde in diesem Gültigkeitsbereich nicht definiert
make[2]: *** [src/core/CMakeFiles/qgis_core.dir/qgsgeometry.o] Fehler 1
make[1]: *** [src/core/CMakeFiles/qgis_core.dir/all] Fehler 2
make: *** [all] Fehler 2

For those of you who can't read the german error messages: It says that 
GEOSLength and GEOSArea aren't defined in the scope.

I tried to grep those symbols in the *.h files of the qgis directory but 
couldn't find it. Maybe you can help me with that one. Or does it happen 
that the current trunk is not compilable?

By the way, I try to do the development in an eclipse ganymede 
environment. Perhaps the one or other has an idea about that.

Best regards


More information about the Qgis-developer mailing list