[Qgis-developer] valuetool crashes qgis

Vincent Schut schut at sarvision.nl
Thu Jun 28 03:15:25 PDT 2012

sorry to reply-to-self...

I set cmake PYTHON_EXECUTABLE to /usr/bin/python2, and PYTHON_LIBRARY to 
/usr/lib/libpython2.7.so, as said in http://hub.qgis.org/issues/5069 
(this is also on arch linux).
qgis builds fine.

however, when I try to install the valuetool plugin, it still crashes 
with a segmentation fault.


On 06/28/2012 11:56 AM, Vincent Schut wrote:
> OK, so I tried to recompile qgis from an emptied build dir, but ccmake 
> gives me this error while configuring:
> CMake Error: The following variables are used in this project, but 
> they are set to NOTFOUND.
>  Please set them or make sure they are set and tested correctly in the 
> CMake files:
>      linked by target "qgispython" in directory 
> /usr/local/src/qgis/src/python
>      linked by target "python_module_qgis_analysis" in directory 
> /usr/local/src/qgis/python
>      linked by target "python_module_qgis_core" in directory 
> /usr/local/src/qgis/python
>      linked by target "python_module_qgis_gui" in directory 
> /usr/local/src/qgis/python
>      linked by target "python_module_qgis_networkanalysis" in 
> directory /usr/local/src/qgis/python
> could that have anything to do with it? Qgis used to build fine, and I 
> definitely have python and pyqt installed. Or is this just because I 
> have both python2.7 and python3.2 installed?
> btw, the source folder was updated from git just yesterday.
> best,
> Vincent.
> On 06/28/2012 10:51 AM, Paolo Cavallini wrote:
>> Il 28/06/2012 08:38, Vincent Schut ha scritto:
>>> Hi,
>>> is it just me, or is the valuetool plugin crashing qgis (current git 
>>> build) when
>>> loading the plugin?
>> I had the same problem, and it turned out being a packaging problem 
>> (different pyqt
>> versions). recompiling solved it.
>> All the best.
> _______________________________________________
> Qgis-developer mailing list
> Qgis-developer at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/qgis-developer

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20120628/d5c49369/attachment-0001.html>

More information about the Qgis-developer mailing list