[Qgis-developer] QGIS 1.9 and SpatiaLite 4 problems

Cline, Royce L. rcline at nd.gov
Wed Apr 17 05:32:20 PDT 2013

If I try to create a new SpatiaLite layer called soils in a new database, I get the following error when I click OK:
soils is an invalid layer and cannot be loaded.
I also tried to create a new layer in both existing version 3 and 4 databases and get the same error.

This on OS X 10.8.3 with nightly build for Lion and Mt. Lion with GDAL 1.10 and SQLite 3.7.16 (includes Spatialite v. 4.0) from KyngChaos.com. Does anybody have this problem on other OS?

Running a pyObjC program that loads SSURGO data into a Spatialite database. The spatial layers in the created SpatiaLite 4 database can be imported into QGIS and appear to display correctly. However, DB Manager shows the spatial layers as tabular data. After using spatialite_convert to convert the database to v. 3, DB Manager correctly displays the spatial tables. Given this, I think that the sqlite framework from KyngChaos is working correctly and that the problem is in QGIS.


More information about the Qgis-developer mailing list