[Qgis-developer] install instructions

Alex Mandel tech_dev at wildintellect.com
Mon Sep 30 10:05:27 PDT 2013

FYI, there's a recently new ppa purge command which is awesome for
cleaning out ppas and stuff they installed back to base system.

As for this issue, I reread some stuff and saw a hint from Victor that
there's a checkbox in the plugin config to enable SAGA 2.0.8 to work
with QGIS 2+

I think SAGA 2.1 will have to wait for newer than Ubuntu 12.04




On 09/30/2013 09:54 AM, Barry Rowlingson wrote:
> Tried adding that PPA, now saga conflicts with itself in synaptic.
> And if I install with apt-get it removes Qgis. If I try and install
> Qgis, it removes Saga.
> $ sudo apt-get install saga
> currently says
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies.
>  saga : Depends: libgdal1 (>= 1.8.0) but it is not going to be installed
>         Depends: liblas1 but it is not going to be installed
> trying to install libgdal1 results in qgis and a bunch of other
> packages being REMOVED (in capitals) - I guess because they use
> libgdal1h? Whatever that is.
> I'm a bit disappointed that I've started from a clean, modern Ubuntu
> install (ok, Mint) and am instantly in some kind of dependency hell. I
> was hoping it would be "add a source, get qgis, get other goodies,
> play".
>  Does this all work off OSGeo Live 7?
> On Mon, Sep 30, 2013 at 5:22 PM, Alex Mandel <tech_dev at wildintellect.com> wrote:
>> On 09/30/2013 07:35 AM, Barry Rowlingson wrote:
>>> On Sun, Sep 29, 2013 at 8:15 PM, Alex Mandel <tech_dev at wildintellect.com> wrote:
>>>> Barry - To clarify again, the Ubuntugis version is the same version of
>>>> QGIS, what differs is GDAL, PROJ and GEOS - by significant version, ie
>>>> gdal 1.8 vs 1.10
>>>> This is critical because 1.10.x supports more of the formats people
>>>> having been asking for like HDF, etc...
>>>  Another annoyance: I can't get SAGA geoprocessing working. I think
>>> this is because the saga version on ubuntugis-unstable is 2.0.8, but
>>> QGIS requires 2.1 according to:
>>> http://docs.qgis.org/2.0/html/en/docs/user_manual/processing/3rdParty.html
>>>  Also, those docs mention an option I can't find: the "SAGA Folder"
>>> setting in the SAGA configuration. Is this supposed to be in the
>>> Processing/Options and Configuration dialog in QGIS 2.0? - Maybe that
>>> will either magically appear when I do get SAGA 2.1 installed or its a
>>> hangover from an earlier QGIS....
>>>  Sorry to bring these up post-release, but I had to upgrade my machine
>>> first and didn't want to do that before FOSS4G!
>>> Barry
>> That's a known packaging issue previous discussed with Johan.
>> SAGA 2.1 requires newer wxwidgets than 12.04 has (which could also
>> effect GRASS). He was hesitant to put wxwidgets in Ubuntugis. I think he
>> was going to ask Victor to make it possible to still use 2.0.8 with
>> Processing/Sextante, which we do have.
>> Or you can get it from https://launchpad.net/~johanvdw/+archive/saga-gis
>> Not sure if it will break GRASS or not.
>> Last discussion on the topic was on in August.
>> Thanks,
>> Alex

More information about the Qgis-developer mailing list