[Qgis-developer] Qt4->Qt5 timeline: Qt4's status and Qt4's webkit removal in Stretch

Sebastiaan Couwenberg sebastic at xs4all.nl
Sat Jan 9 02:08:31 PST 2016


On 10-05-15 14:44, Sebastiaan Couwenberg wrote:
> On 05/10/2015 02:16 PM, Anita Graser wrote:
>> On Sun, May 10, 2015 at 1:45 PM, Paolo Cavallini wrote:
>>> Seems a rather serious issue. Shouldn't we reconsider our roadmap
>>> accordingly?
>>>
>>
>> ‚ÄčI don't seem to be able to find any dates mentioned in the linked
>> resources. When (date) will Debian remove Qt4?
> 
> The Debian Qt maintainers didn't give definitive dates in their
> announcement [1], but they mention that Qt upstream is about to release
> the last Qt4 point release (4.8.7), Qt upstream also recommends keeping
> Qt4 until 2017 which translates to the end of the jessie stable release.
> 
> The next two years must be used to move away from Qt4 to Qt5. During
> that time Qt4 components will be removed when they cannot be supported
> anymore. The Qt4 Webkit component will be the first to go. Regarding its
> removal the Qt maintainers said:
> 
> "
>  Of course we still have a lot of KDE stuff using Qt4's webkit, so it
>  won't disappear "soon", but it will at some point.
> "
> 
> [1] https://lists.debian.org/debian-devel-announce/2015/05/msg00001.html

The severity of the "Qt4's WebKit removal" bugreport in Debian has been
raised to serious (Release Critical), because a "new python-qt4 upload
with removed QtWebKit module will happen shortly".

QGIS will no longer build on Debian sid after this upload as long as it
requires Qt4's WebKit.

Kind Regards,

Bas

-- 
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1


More information about the Qgis-developer mailing list