[QGIS-Developer] Running QGIS 2.18 and QGIS 3 together?

Marco Grisolia marco.grisolia5 at gmail.com
Thu May 11 02:07:18 PDT 2017

I'm currently running QGIS 2.18.7 on a Win64bit machine, which I installed
using OsGeo4W Network Installer (32bit).
I recently installed the 2.99dev version and I encountered this error when
trying to start QGIS 3:

"Impossible to find the entry point [...] qwt.dll"

After a quick search, I found it in two different paths (as expected):

Path1: 'C:\OSGeo4W\bin\qwt.dll'

Path2: 'C:\OSGeo4W\apps\Qt5\bin\qwt.dll'

I know that this issue can be solved by renaming it in the proper location,
so I renamed the .dll file in the Path1 and, as expected, QGIS 3 WORKED
without any problem.

However, now the problem is reversed: I'm able to run QGIS 3, but I can't
run QGIS 2.18.7 anymore unless I rename again the .dll file in the Path1.
Is there a way for having both QGIS versions working without always
renaming the .dll file?

I want to remark that the "renaming procedure" allows running only one QGIS
version, while I wish to work with both of them (I'm quite sure I
didn't consider some simple workaround!).

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20170511/c71c7652/attachment.html>

More information about the QGIS-Developer mailing list