[QGIS-Developer] [Qgis-developer] Min Qt version
nyall.dawson at gmail.com
Thu May 25 01:53:40 PDT 2017
On 25 May 2017 at 17:18, Radim Blazek <radim.blazek at gmail.com> wrote:
> On Mon, Feb 20, 2017 at 11:42 AM, Denis Rouzaud <denis.rouzaud at gmail.com> wrote:
>>> On Tue, Feb 7, 2017 at 10:43 AM, Jürgen E. Fischer <jef at norbit.de> wrote:
>>>> On Tue, 07. Feb 2017 at 09:11:25 +1000, Nyall Dawson wrote:
>>>>>> INSTALL says in requirements Qt >= 5.3.0, Debian stable has 5.3.2.
>>>>> That's a mistake. AFAIK we are targeting 5.3 to cater for Debian.
>>>> Debian jessie (stable) has GDAL 1.10.1 - too old for us.
>>> On Tue, Feb 7, 2017 at 10:51 AM, Nyall Dawson <nyall.dawson at gmail.com> wrote:
>>> Ah - I didn't realise. So what's the minimum target now? 5.5 to match Xenial?
>> Is there a decision here?
>> What min Qt version is the requirement: 5.3 or 5.7?
> I can just confirm again that Qt 5.3 is not enough, for example (but
> there will be more):
> What min version of Qt are you able to compile with? We should update INSTALL.
> In INSTALL requirements it is also written: Qwt >= 5.0 & (< 6.1 with
> internal QwtPolar)
> but Qwt 6.0 does not compile with Qt >= 5.4:
> Is it still true that Qwt must be < 6.1? I have compiled with 6.1.3
> (but not tested related functionality).
I can't help with minimum Qt version (it's either 5.4 or 5.5, but I
don't believe a firm decision has been made), but the minimum Qwt is
6.1. In this case the INSTALL is incorrect and needs to be updated.
More information about the QGIS-Developer