[QGIS-Developer] joined MemoryLayer gives wrong featurecount

Richard Duivenvoorde rdmailings at duif.net
Fri May 4 00:19:44 PDT 2018

Hi Devs,

See screenshot: top is jsononly-copy, then a geometry-less memory layer
which is joined to the bottom layer.

After creating the join: all is fine: featurecount is ok.
Reopening the project, the count is always zero.
The classification though is going OK! (bottom layer looks fine)
Reopening Layerproperties/style dialog and click OK features are
apperently recounted and again ok.

After I tried to debug it, I get the feeling that the
featurecounter-task-run is started a little too early, and the
expressions needed to evaluate for the counting are not ready yet.
Not sure if the memory layer is the problem or the join.
Also tried categorized style: same problem.

Can I force a 'recount' of the features?
Tried mapCanvas.update() etc... but featurecount does not change.

I like to create an issue for it, but it is hard to provide an example
dataset as the 'memory-layer' is filled via a plugin upon startup...

So hoping this first description rings a bell with somebody.


Richard Duivenvoorde

-------------- next part --------------
A non-text attachment was scrubbed...
Name: joinedplusgeojsononly.png
Type: image/png
Size: 72776 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/qgis-developer/attachments/20180504/a77e53f5/attachment-0001.png>

More information about the QGIS-Developer mailing list